# CVE-2025-67857: Moodle: moodle: data exposure of user identifiers in urls

> Attackers can view internal user IDs in URLs during anonymous submissions, compromising anonymity and exposing sensitive user data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 3 Feb 2026
- **Also known as:** BIT-moodle-2025-67857, GHSA-8jrv-wx83-w3xj, UBUNTU-CVE-2025-67857

## What is CVE-2025-67857?

CVE-2025-67857 is a medium-severity vulnerability in Moodle Moodle, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in moodle. During anonymous assignment submissions, user identifiers were inadvertently exposed in URLs. This data exposure allows unauthorized viewers to see internal user IDs, compromising the intended anonymity and potentially leading to information disclosure.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2025-67857?

11 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.1.22 |
| `moodle/moodle` | Packagist | All versions | 4.1.22 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.12 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.12 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.8 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.8 |
| `moodle/moodle` | Packagist | From 5.0.0-beta | 5.0.4 |
| `moodle/moodle` | Packagist | From 5.0.0-beta | 5.0.4 |
| `moodle/moodle` | Packagist | From 5.1.0-beta | 5.1.1 |
| `moodle/moodle` | Packagist | From 5.1.0-beta | 5.1.1 |
| `moodle` | Bitnami | All versions | 4.1.21, 4.4.11, 4.5.8, 5.0.4, 5.1.1 |

Products: Moodle Moodle.

## How do I fix CVE-2025-67857?

Upgrade moodle/moodle to a fixed version for your release line: 4.1.22, 4.4.12, 4.5.8 or 5.0.4.

## Is CVE-2025-67857 being exploited?

There is no known exploitation of CVE-2025-67857 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67857 and fix it if it is affected.

What it is: CVE-2025-67857 is a medium-severity vulnerability in Moodle Moodle, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67857 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.22
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.22
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.12
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.12
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.8
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.8
- moodle/moodle (Packagist): affected from 5.0.0-beta; fixed in 5.0.4
- moodle/moodle (Packagist): affected from 5.0.0-beta; fixed in 5.0.4
- moodle/moodle (Packagist): affected from 5.1.0-beta; fixed in 5.1.1
- moodle/moodle (Packagist): affected from 5.1.0-beta; fixed in 5.1.1
- moodle (Bitnami): affected all versions; fixed in 4.1.21, 4.4.11, 4.5.8, 5.0.4, 5.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67857/ (Markdown: https://insights.sbomify.com/CVE-2025-67857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67857
- OSV: https://osv.dev/vulnerability/CVE-2025-67857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67857/
Summaries are generated and may contain mistakes; the official description above is the record.
