# CVE-2025-67860: NeuVector scanner insecurely handles passwords as command arguments

> Local users can expose registry and controller credentials by inspecting command-line arguments of the NeuVector scanner process.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 25 Feb 2026
- **Also known as:** GHSA-3c9m-gq32-g4jx, GO-2026-4490

## What is CVE-2025-67860?

CVE-2025-67860 is a low-severity vulnerability in SUSE harvester, published on 25 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been identified in the NeuVector scanner where the scanner process accepts registry and controller credentials as command-line arguments, potentially exposing sensitive credentials to local users.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2025-67860?

3 open source packages ship an affected version, including github.com/neuvector/scanner.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/neuvector/scanner` | Go | All versions | None |
| `github.com/neuvector/scanner` | Go | From 4.0 | 4.072 |
| `github.com/neuvector/scanner` | Go | From 4.0 | 4.072 |

## How do I fix CVE-2025-67860?

Upgrade github.com/neuvector/scanner to 4.072 or later.

## Is CVE-2025-67860 being exploited?

There is no known exploitation of CVE-2025-67860 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67860 and fix it if it is affected.

What it is: CVE-2025-67860 is a low-severity vulnerability in SUSE harvester, published on 25 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67860 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/neuvector/scanner (Go): affected all versions; no fix listed
- github.com/neuvector/scanner (Go): affected from 4.0; fixed in 4.072
- github.com/neuvector/scanner (Go): affected from 4.0; fixed in 4.072

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67860/ (Markdown: https://insights.sbomify.com/CVE-2025-67860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67860
- OSV: https://osv.dev/vulnerability/CVE-2025-67860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67860/
Summaries are generated and may contain mistakes; the official description above is the record.
