{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow-providers-edge3 and apache-airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-67895 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-edge3 to 2.0.0 or later.","what":"CVE-2025-67895 is a critical code injection vulnerability in Apache Airflow Providers Edge3, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-67895 and fix it if it is affected.\n\nWhat it is: CVE-2025-67895 is a critical code injection vulnerability in Apache Airflow Providers Edge3, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-67895 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-edge3 (PyPI): affected all versions; fixed in 2.0.0\n- apache-airflow-providers-edge3 (PyPI): affected all versions; fixed in 2.0.0\n- apache-airflow-providers-edge3 (PyPI): affected all versions; fixed in 2.0.0\n- apache-airflow (PyPI): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67895/ (Markdown: https://insights.sbomify.com/CVE-2025-67895/index.md)","id":"CVE-2025-67895","markdown":"https://insights.sbomify.com/CVE-2025-67895/index.md","name":"CVE-2025-67895","record":{"aliases":["GHSA-66h8-3g48-6hx8","PYSEC-2025-87","PYSEC-2026-276"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Airflow plugin","requires_auth":"none","summary":"Attackers with DAG author privileges can execute arbitrary code in the webserver context if the Edge3 provider is installed on Airflow 2.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-edge3","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-669","name":"Incorrect Resource Transfer Between Spheres"}],"description":"Edge3 Worker RPC RCE on Airflow 2.\n\nThis issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if you installed and configured it on Airflow 2.\n\nThe Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if you installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do.\n\nIf you installed and configured Edge3 provider for Airflow 2, you should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (\u003e=2.0.0) has minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2.\n\nIf you used Edge Provider in Airflow 3, you are not affected.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Providers Edge3: Edge3 Worker RPC RCE on Airflow 2","id":"CVE-2025-67895","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"Memory corruption in Exim","id":"CVE-2025-67896"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2025-87"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-edge3","purl":null,"source":"GHSA-66h8-3g48-6hx8"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-edge3","purl":"pkg:pypi/apache-airflow-providers-edge3","source":"GHSA-66h8-3g48-6hx8"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-edge3","purl":"pkg:pypi/apache-airflow-providers-edge3","source":"PYSEC-2026-276"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2025-67888"},"products":["Apache Airflow Providers Edge3"],"published":"2025-12-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-17","vendors":["Apache Software Foundation"]},"summary":"Attackers with DAG author privileges can execute arbitrary code in the webserver context if the Edge3 provider is installed on Airflow 2.","url":"https://insights.sbomify.com/CVE-2025-67895/"}