# CVE-2025-67895: Apache Airflow Providers Edge3: Edge3 Worker RPC RCE on Airflow 2

> Attackers with DAG author privileges can execute arbitrary code in the webserver context if the Edge3 provider is installed on Airflow 2.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2025
- **Updated:** 17 Dec 2025
- **Also known as:** GHSA-66h8-3g48-6hx8, PYSEC-2025-87, PYSEC-2026-276

## What is CVE-2025-67895?

CVE-2025-67895 is a critical code injection vulnerability in Apache Airflow Providers Edge3, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Edge3 Worker RPC RCE on Airflow 2.

This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if you installed and configured it on Airflow 2.

The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if you installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do.

If you installed and configured Edge3 provider for Airflow 2, you should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2.

If you used Edge Provider in Airflow 3, you are not affected.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres)

## Which versions are affected by CVE-2025-67895?

4 open source packages ship an affected version, including apache-airflow-providers-edge3 and apache-airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-edge3` | PyPI | All versions | 2.0.0 |
| `apache-airflow-providers-edge3` | PyPI | All versions | 2.0.0 |
| `apache-airflow-providers-edge3` | PyPI | All versions | 2.0.0 |
| `apache-airflow` | PyPI | All versions | 2.0.0 |

Products: Apache Apache-Airflow-Providers-Edge3.

## How do I fix CVE-2025-67895?

Upgrade apache-airflow-providers-edge3 to 2.0.0 or later.

## Is CVE-2025-67895 being exploited?

There is no known exploitation of CVE-2025-67895 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67895 and fix it if it is affected.

What it is: CVE-2025-67895 is a critical code injection vulnerability in Apache Airflow Providers Edge3, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67895 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-edge3 (PyPI): affected all versions; fixed in 2.0.0
- apache-airflow-providers-edge3 (PyPI): affected all versions; fixed in 2.0.0
- apache-airflow-providers-edge3 (PyPI): affected all versions; fixed in 2.0.0
- apache-airflow (PyPI): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67895/ (Markdown: https://insights.sbomify.com/CVE-2025-67895/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67895
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67895
- OSV: https://osv.dev/vulnerability/CVE-2025-67895

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67895/
Summaries are generated and may contain mistakes; the official description above is the record.
