{"answers":{"affected":"3 open source packages ship an affected version, including sequoia-openpgp.","exploited":"There is no known exploitation of CVE-2025-67897 in the wild and no public exploit code.","fix":"Upgrade sequoia-openpgp to 2.1.0 or later.","what":"CVE-2025-67897 is a medium-severity denial of service vulnerability in sequoia-pgp sequoia, published on 14 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-67897 and fix it if it is affected.\n\nWhat it is: CVE-2025-67897 is a medium-severity denial of service vulnerability in sequoia-pgp sequoia, published on 14 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-67897 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sequoia-openpgp (crates.io): affected all versions; fixed in 2.1.0\n- sequoia-openpgp (crates.io): affected all versions; fixed in 2.1.0\n- sequoia-openpgp (crates.io): affected from 0.0.0-0; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67897/ (Markdown: https://insights.sbomify.com/CVE-2025-67897/index.md)","id":"CVE-2025-67897","markdown":"https://insights.sbomify.com/CVE-2025-67897/index.md","name":"CVE-2025-67897","record":{"aliases":["DEBIAN-CVE-2025-67897","GHSA-v6x3-9r38-r27q","RUSTSEC-2025-0136","UBUNTU-CVE-2025-67897"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Sequoia PGP library","requires_auth":"none","summary":"A remote attacker can crash applications using the Sequoia PGP library by sending crafted encrypted messages with short ciphertexts.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-195","name":"Signed to Unsigned Conversion Error"}],"description":"In Sequoia before 2.1.0, aes_key_unwrap panics if passed a ciphertext that is too short. A remote attacker can take advantage of this issue to crash an application by sending a victim an encrypted message with a crafted PKESK or SKESK packet.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sequoia PGP has Subtraction Overflow when aes_key_unwrap function is provided ciphertext that is too short","id":"CVE-2025-67897","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"MJML allows mj-include directory traversal due to an incomplete fix for CVE-2020-12827","id":"CVE-2025-67898"},"packages":[{"ecosystem":"crates.io","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"sequoia-openpgp","purl":null,"source":"GHSA-v6x3-9r38-r27q"},{"ecosystem":"crates.io","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"sequoia-openpgp","purl":"pkg:cargo/sequoia-openpgp","source":"GHSA-v6x3-9r38-r27q"},{"ecosystem":"crates.io","fixed":["2.1.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"sequoia-openpgp","purl":"pkg:cargo/sequoia-openpgp","source":"RUSTSEC-2025-0136"}],"prev":{"headline":"Memory corruption in Exim","id":"CVE-2025-67896"},"products":["sequoia"],"published":"2025-12-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-15","vendors":["sequoia-pgp"]},"summary":"A remote attacker can crash applications using the Sequoia PGP library by sending crafted encrypted messages with short ciphertexts.","url":"https://insights.sbomify.com/CVE-2025-67897/"}