# CVE-2025-67897: Sequoia PGP has Subtraction Overflow when aes_key_unwrap function is provided ciphertext that is too short

> A remote attacker can crash applications using the Sequoia PGP library by sending crafted encrypted messages with short ciphertexts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Dec 2025
- **Updated:** 15 Dec 2025
- **Also known as:** DEBIAN-CVE-2025-67897, GHSA-v6x3-9r38-r27q, RUSTSEC-2025-0136, UBUNTU-CVE-2025-67897

## What is CVE-2025-67897?

CVE-2025-67897 is a medium-severity denial of service vulnerability in sequoia-pgp sequoia, published on 14 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Sequoia before 2.1.0, aes_key_unwrap panics if passed a ciphertext that is too short. A remote attacker can take advantage of this issue to crash an application by sending a victim an encrypted message with a crafted PKESK or SKESK packet.

Weakness: CWE-195 (Signed to Unsigned Conversion Error)

## Which versions are affected by CVE-2025-67897?

3 open source packages ship an affected version, including sequoia-openpgp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sequoia-openpgp` | crates.io | All versions | 2.1.0 |
| `sequoia-openpgp` | crates.io | All versions | 2.1.0 |
| `sequoia-openpgp` | crates.io | From 0.0.0-0 | 2.1.0 |

## How do I fix CVE-2025-67897?

Upgrade sequoia-openpgp to 2.1.0 or later.

## Is CVE-2025-67897 being exploited?

There is no known exploitation of CVE-2025-67897 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67897 and fix it if it is affected.

What it is: CVE-2025-67897 is a medium-severity denial of service vulnerability in sequoia-pgp sequoia, published on 14 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67897 in the wild and no public exploit code.

Affected packages and fixed versions:
- sequoia-openpgp (crates.io): affected all versions; fixed in 2.1.0
- sequoia-openpgp (crates.io): affected all versions; fixed in 2.1.0
- sequoia-openpgp (crates.io): affected from 0.0.0-0; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67897/ (Markdown: https://insights.sbomify.com/CVE-2025-67897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67897
- OSV: https://osv.dev/vulnerability/CVE-2025-67897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67897/
Summaries are generated and may contain mistakes; the official description above is the record.
