{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-67899 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-67899 is a low-severity denial of service vulnerability in uriparser, published on 14 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-67899 and fix it if it is affected.\n\nWhat it is: CVE-2025-67899 is a low-severity denial of service vulnerability in uriparser, published on 14 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-67899 in the wild and no public exploit code.\n\nAffected product: uriparser. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67899/ (Markdown: https://insights.sbomify.com/CVE-2025-67899/index.md)","id":"CVE-2025-67899","markdown":"https://insights.sbomify.com/CVE-2025-67899/index.md","name":"CVE-2025-67899","record":{"aliases":["AZL-72379","AZL-72862","DEBIAN-CVE-2025-67899","ECHO-fafd-c1a0-0f9d","GHSA-h2vr-rqqp-xv8m","RHSA-2026:7642","SUSE-SU-2026:0444-1","SUSE-SU-2026:22084-1","UBUNTU-CVE-2025-67899","USN-8409-1","openSUSE-SU-2026:10045-1","openSUSE-SU-2026:10595-1","openSUSE-SU-2026:20910-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"URI parsing library","requires_auth":"none","summary":"Attackers can cause denial of service via unbounded recursion in the uriparser library by providing large inputs with many commas.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"uriparser through 0.9.9 allows unbounded recursion and stack consumption, as demonstrated by ParseMustBeSegmentNzNc with large input containing many commas.","ecosystems":["Red Hat:hummingbird:1","SUSE:Linux Enterprise Module for Package Hub 15 SP7","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server for SAP applications 16.0","openSUSE:Leap 15.6","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in uriparser","id":"CVE-2025-67899","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":12,"n_references":2,"next":{"headline":"Code injection in NXLog Agent","id":"CVE-2025-67900"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.0.0-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"mingw32-uriparser","purl":"pkg:rpm/redhat/mingw32-uriparser","source":"RHSA-2026:7642"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.0.0-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"mingw64-uriparser","purl":"pkg:rpm/redhat/mingw64-uriparser","source":"RHSA-2026:7642"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.0.0-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"uriparser","purl":"pkg:rpm/redhat/uriparser","source":"RHSA-2026:7642"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.0.0-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"uriparser-devel","purl":"pkg:rpm/redhat/uriparser-devel","source":"RHSA-2026:7642"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.0.0-2.1.hum1"],"introduced":["0"],"last_affected":[],"package":"uriparser-doc","purl":"pkg:rpm/redhat/uriparser-doc","source":"RHSA-2026:7642"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["0.8.5-150000.3.11.1"],"introduced":["0"],"last_affected":[],"package":"uriparser","purl":"pkg:rpm/suse/uriparser\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2026:0444-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["0.9.8-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"uriparser","purl":"pkg:rpm/suse/uriparser\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22084-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["0.9.8-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"uriparser","purl":"pkg:rpm/suse/uriparser\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22084-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["0.8.5-150000.3.11.1"],"introduced":["0"],"last_affected":[],"package":"uriparser","purl":"pkg:rpm/opensuse/uriparser\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2026:0444-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["0.9.8-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"uriparser","purl":"pkg:rpm/opensuse/uriparser\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20910-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["8.5.5-1.1"],"introduced":["0"],"last_affected":[],"package":"php8","purl":"pkg:rpm/opensuse/php8\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10595-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.0.0-1.1"],"introduced":["0"],"last_affected":[],"package":"uriparser","purl":"pkg:rpm/opensuse/uriparser\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10045-1"}],"prev":{"headline":"MJML allows mj-include directory traversal due to an incomplete fix for CVE-2020-12827","id":"CVE-2025-67898"},"products":["uriparser"],"published":"2025-12-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-15","vendors":["uriparser project"]},"summary":"Attackers can cause denial of service via unbounded recursion in the uriparser library by providing large inputs with many commas.","url":"https://insights.sbomify.com/CVE-2025-67899/"}