CVE-2025-68113 ALTCHA Proof-of-Work Vulnerable to Challenge Splicing and Replay
Attackers can replay solved captcha challenges by splicing parameters, bypassing bot protection and rate limiting mechanisms.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68113?
CVE-2025-68113 is a medium-severity vulnerability in altcha-org altcha-lib, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ALTCHA is privacy-first software for captcha and bot protection. A cryptographic semantic binding flaw in ALTCHA libraries allows challenge payload splicing, which may enable replay attacks. The HMAC signature does not unambiguously bind challenge parameters to the nonce, allowing an attacker to reinterpret a valid proof-of-work submission with a modified expiration value. This may allow previously solved challenges to be reused beyond their intended lifetime, depending on server-side replay handling and deployment assumptions. The vulnerability primarily impacts abuse-prevention mechanisms such as rate limiting and bot mitigation. It does not directly affect data confidentiality or integrity. This issue has been addressed by enforcing explicit semantic separation between challenge parameters and the nonce during HMAC computation. Users are advised to upgrade to patched versions, which include version 1.0.0 of the altcha Golang package, version 1.0.0 of the altcha Rubygem, version 1.0.0 of the altcha pip package, version 1.0.0 of the altcha Erlang package, version 1.4.1 of the altcha-lib npm package, version 1.3.1 of the altcha-org/altcha Composer package, and version 1.3.0 of the org.altcha:altcha Maven package. As a mitigation, implementations may append a delimiter to the end of the `salt` value prior to HMAC computation (for example, `<salt>?expires=<time>&`). This prevents ambiguity between parameters and the nonce and is backward-compatible with existing implementations, as the delimiter is treated as a standard URL parameter separator.
Which versions are affected by CVE-2025-68113?
16 open source packages ship an affected version, including github.com/altcha-org/altcha-lib-go, altcha and org.altcha:altcha.
| Package | Affected | Fixed in |
|---|---|---|
github.com/altcha-org/altcha-lib-go Go | All versions | 1.0.0 |
github.com/altcha-org/altcha-lib-go Go | All versions | 1.0.0 |
github.com/altcha-org/altcha-lib-go Go | All versions | 1.0.0 |
altcha Hex | All versions | 1.0.0 |
altcha Hex | All versions | 1.0.0 |
org.altcha:altcha Maven | All versions | 1.3.0 |
10 more packages
org.altcha:altcha Maven | All versions | 1.3.0 |
altcha-org/altcha Packagist | All versions | 1.3.1 |
altcha-org/altcha Packagist | All versions | 1.3.1 |
altcha PyPI | All versions | 1.0.0 |
altcha PyPI | All versions | 1.0.0 |
altcha PyPI | All versions | 1.0.0 |
altcha RubyGems | All versions | 1.0.0 |
altcha RubyGems | All versions | 1.0.0 |
altcha-lib npm | All versions | 1.4.1 |
altcha-lib npm | All versions | 1.4.1 |
How do I fix CVE-2025-68113?
Upgrade github.com/altcha-org/altcha-lib-go to 1.0.0 or later.
Is CVE-2025-68113 being exploited?
There is no known exploitation of CVE-2025-68113 in the wild and no public exploit code.
Sources
Also known as GHSA-6gvq-jcmp-8959, GO-2025-4239, PYSEC-2026-1115.