CVE-2025-68115 Parse Server vulnerable to Cross-Site Scripting (XSS) via Unescaped Mustache Template Variables

Medium 5.3 Published Updated

Attackers can execute arbitrary scripts in victims' browsers via unescaped variables in password reset and email verification pages, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-68115?

CVE-2025-68115 is a medium-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available.

Weakness: CWE-79

Which versions are affected by CVE-2025-68115?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions8.6.1
parse-server npmAll versions8.6.1
parse-server npmFrom 9.0.09.1.0-alpha.3
parse-server npmFrom 9.0.09.1.0-alpha.3
parse BitnamiAll versions8.6.1, 9.1.0

Products include Parseplatform Parse-Server.

How do I fix CVE-2025-68115?

Upgrade parse-server to a fixed version for your release line: 8.6.1 or 9.1.0-alpha.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-68115 being exploited?

There is no known exploitation of CVE-2025-68115 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2025-68115, GHSA-jhgf-2h8h-ggxv.

Is CVE-2025-68115 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free