# CVE-2025-68115: Parse Server vulnerable to Cross-Site Scripting (XSS) via Unescaped Mustache Template Variables

> Attackers can execute arbitrary scripts in victims' browsers via unescaped variables in password reset and email verification pages, potentially leading to account takeover.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Dec 2025
- **Updated:** 16 Dec 2025
- **Also known as:** BIT-parse-2025-68115, GHSA-jhgf-2h8h-ggxv

## What is CVE-2025-68115?

CVE-2025-68115 is a medium-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-68115?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.1 |
| `parse-server` | npm | All versions | 8.6.1 |
| `parse-server` | npm | From 9.0.0 | 9.1.0-alpha.3 |
| `parse-server` | npm | From 9.0.0 | 9.1.0-alpha.3 |
| `parse` | Bitnami | All versions | 8.6.1, 9.1.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2025-68115?

Upgrade parse-server to a fixed version for your release line: 8.6.1 or 9.1.0-alpha.3.

## Is CVE-2025-68115 being exploited?

There is no known exploitation of CVE-2025-68115 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68115 and fix it if it is affected.

What it is: CVE-2025-68115 is a medium-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-68115 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.1
- parse-server (npm): affected all versions; fixed in 8.6.1
- parse-server (npm): affected from 9.0.0; fixed in 9.1.0-alpha.3
- parse-server (npm): affected from 9.0.0; fixed in 9.1.0-alpha.3
- parse (Bitnami): affected all versions; fixed in 8.6.1, 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68115/ (Markdown: https://insights.sbomify.com/CVE-2025-68115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68115
- OSV: https://osv.dev/vulnerability/CVE-2025-68115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68115/
Summaries are generated and may contain mistakes; the official description above is the record.
