{"answers":{"affected":"2 open source packages ship an affected version, including auth0/auth0-php. It affects 4 products.","exploited":"There is no known exploitation of CVE-2025-68129 in the wild and no public exploit code.","fix":"Upgrade auth0/auth0-php to 8.18.0 or later.","what":"CVE-2025-68129 is a medium-severity authentication bypass vulnerability in auth0-PHP, published on 17 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-68129 and fix it if it is affected.\n\nWhat it is: CVE-2025-68129 is a medium-severity authentication bypass vulnerability in auth0-PHP, published on 17 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-68129 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/auth0-php (Packagist): affected from 8.0.0; fixed in 8.18.0\n- auth0/auth0-php (Packagist): affected from 8.0.0; fixed in 8.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68129/ (Markdown: https://insights.sbomify.com/CVE-2025-68129/index.md)","id":"CVE-2025-68129","markdown":"https://insights.sbomify.com/CVE-2025-68129/index.md","name":"CVE-2025-68129","record":{"aliases":["GHSA-j2vm-wrq3-f7gf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Auth0 PHP SDK","requires_auth":"low_privilege","summary":"Improper audience validation in the Auth0-PHP SDK allows attackers to use ID tokens as Access tokens, bypassing authentication checks.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"auth0-php","vendor":"auth0"},{"product":"laravel-auth0","vendor":"auth0"},{"product":"symfony","vendor":"auth0"},{"product":"wp-auth0","vendor":"auth0"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. Projects are affected if they use Auth0-PHP SDK versions between v8.0.0 and v8.17.0, or applications using the following SDKs that rely on the Auth0-PHP SDK versions between v8.0.0 and v8.17.0: Auth0/symfony versions between 5.0.0 and 5.5.0, Auth0/laravel-auth0 versions between 7.0.0 and 7.19.0, and/or Auth0/wordpress plugin versions between 5.0.0-BETA0 and 5.4.0. Auth0/Auth0-PHP version 8.18.0 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth0-PHP SDK has Improper Audience Validation","id":"CVE-2025-68129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":12,"next":{"headline":"tRPC has possible prototype pollution in `experimental_nextAppDirCaller`","id":"CVE-2025-68130"},"packages":[{"ecosystem":"Packagist","fixed":["8.18.0"],"introduced":["8.0.0"],"last_affected":[],"package":"auth0/auth0-php","purl":null,"source":"GHSA-j2vm-wrq3-f7gf"},{"ecosystem":"Packagist","fixed":["8.18.0"],"introduced":["8.0.0"],"last_affected":[],"package":"auth0/auth0-php","purl":"pkg:composer/auth0/auth0-php","source":"GHSA-j2vm-wrq3-f7gf"}],"prev":{"headline":"reserved but not needed","id":"CVE-2025-68128"},"products":["auth0-PHP"],"published":"2025-12-17","related":[{"cvss_score":8.2,"headline":"Auth0 PHP SDK Insufficient Entropy in Cookie Encryption","id":"CVE-2026-34236","kev_date_added":null,"published":"2026-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-18","vendors":["auth0"]},"summary":"Improper audience validation in the Auth0-PHP SDK allows attackers to use ID tokens as Access tokens, bypassing authentication checks.","url":"https://insights.sbomify.com/CVE-2025-68129/"}