# CVE-2025-68145: mcp-server-git has missing path validation when using --repository flag

> Attackers can access or modify unauthorized Git repositories by bypassing path restrictions in the mcp-server-git tool when configured with a specific repository flag.

- **Severity:** Medium 6.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** GHSA-j22h-9j4x-23w5, MINI-42c5-m8rr-5442, PYSEC-2026-1623

## What is CVE-2025-68145?

CVE-2025-68145 is a medium-severity path traversal vulnerability in modelcontextprotocol servers, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In mcp-server-git versions prior to 2025.12.17, when the server is started with the --repository flag to restrict operations to a specific repository path, it did not validate that repo_path arguments in subsequent tool calls were actually within that configured path. This could allow tool calls to operate on other repositories accessible to the server process. The fix adds path validation that resolves both the configured repository and the requested path (following symlinks) and verifies the requested path is within the allowed repository before executing any git operations. Users are advised to upgrade to 2025.12.17 upon release to remediate this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-68145?

3 open source packages ship an affected version, including mcp-server-git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-server-git` | PyPI | All versions | 2025.12.18 |
| `mcp-server-git` | PyPI | All versions | 2025.12.18 |
| `mcp-server-git` | PyPI | All versions | 2025.12.18 |

Products: Lfprojects Model Context Protocol Servers.

## How do I fix CVE-2025-68145?

Upgrade mcp-server-git to 2025.12.18 or later.

## Is CVE-2025-68145 being exploited?

There is no known exploitation of CVE-2025-68145 in the wild and no public exploit code.

## Other vulnerabilities in modelcontextprotocol servers

- [CVE-2025-68143](https://insights.sbomify.com/CVE-2025-68143/): mcp-server-git's unrestricted git_init tool allows repository creation at arbitrary filesystem locations (medium 6.5)
- [CVE-2026-27735](https://insights.sbomify.com/CVE-2026-27735/): mcp-server-git : Path traversal in git_add allows staging files outside repository boundaries (medium 6.4)
- [CVE-2025-68144](https://insights.sbomify.com/CVE-2025-68144/): mcp-server-git argument injection in git_diff and git_checkout functions allows overwriting local files (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68145 and fix it if it is affected.

What it is: CVE-2025-68145 is a medium-severity path traversal vulnerability in modelcontextprotocol servers, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-68145 in the wild and no public exploit code.

Affected packages and fixed versions:
- mcp-server-git (PyPI): affected all versions; fixed in 2025.12.18
- mcp-server-git (PyPI): affected all versions; fixed in 2025.12.18
- mcp-server-git (PyPI): affected all versions; fixed in 2025.12.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68145/ (Markdown: https://insights.sbomify.com/CVE-2025-68145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68145
- OSV: https://osv.dev/vulnerability/CVE-2025-68145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68145/
Summaries are generated and may contain mistakes; the official description above is the record.
