{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68147 exists.","fix":"No fix has been published for CVE-2025-68147 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-68147 is a high-severity cross-site scripting vulnerability in opensourcepos, published on 17 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-68147 and fix it if it is affected.\n\nWhat it is: CVE-2025-68147 is a high-severity cross-site scripting vulnerability in opensourcepos, published on 17 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68147 exists.\n\nAffected product: opensourcepos. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68147/ (Markdown: https://insights.sbomify.com/CVE-2025-68147/index.md)","id":"CVE-2025-68147","markdown":"https://insights.sbomify.com/CVE-2025-68147/index.md","name":"CVE-2025-68147","record":{"aliases":["GHSA-xgr7-7pvw-fpmh"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Point of Sale application","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts into the Return Policy field, leading to session hijacking and data theft for users viewing receipts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"open_source_point_of_sale","vendor":"opensourcepos"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. Starting in version 3.4.0 and prior to version 3.4.2, a Stored Cross-Site Scripting (XSS) vulnerability exists in the \"Return Policy\" configuration field. The application does not properly sanitize user input before saving it to the database or displaying it on receipts. An attacker with access to the \"Store Configuration\" (such as a rogue administrator or an account compromised via the separate CSRF vulnerability) can inject malicious JavaScript payloads into this field. These payloads are executed in the browser of any user (including other administrators and sales staff) whenever they view a receipt or complete a transaction. This can lead to session hijacking, theft of sensitive data, or unauthorized actions performed on behalf of the victim. The vulnerability has been patched in version 3.4.2 by ensuring the output is escaped using the `esc()` function in the receipt template. As a temporary mitigation, administrators should ensure the \"Return Policy\" field contains only plain text and strictly avoid entering any HTML tags. There is no code-based workaround other than applying the patch.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-12-17","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-12-17T17:30:02Z","kind":"github_poc","ref":"https://github.com/Nixon-H/CVE-2025-68147-OSPOS-Stored-XSS","stars":2,"title":"PoC repository for CVE-2025-68147: Stored Cross-Site Scripting (XSS) in OpenSourcePOS. Vulnerability allows privilege escalation via malicious JavaScript injection in the Store Config module. Includes payload details and patch verification (v3.4.0). Security Researcher: Aditya Singh (Nixon-H)."}],"tier":"weaponised"},"has_fix":false,"headline":"opensourcepos has a Cross-site Scripting vulnerability","id":"CVE-2025-68147","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"FreshRSS globally denies access to feed via proxy modifying to 429 Retry-After","id":"CVE-2025-68148"},"packages":[],"prev":{"headline":"filelock has TOCTOU race condition that allows symlink attacks during lock file creation","id":"CVE-2025-68146"},"products":["opensourcepos"],"published":"2025-12-17","related":[{"cvss_score":8.8,"headline":"Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality","id":"CVE-2026-32888","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":8.8,"headline":"Path traversal in n/a","id":"CVE-2026-26746","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":8.8,"headline":"opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation","id":"CVE-2025-68434","kev_date_added":null,"published":"2025-12-17"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2025-63800","kev_date_added":null,"published":"2025-11-18"},{"cvss_score":7.4,"headline":"Command injection in n/a","id":"CVE-2025-70093","kev_date_added":null,"published":"2026-02-13"},{"cvss_score":7.2,"headline":"Cross-site scripting in n/a","id":"CVE-2025-66921","kev_date_added":null,"published":"2025-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-18","vendors":["opensourcepos"]},"summary":"Attackers can inject malicious scripts into the Return Policy field, leading to session hijacking and data theft for users viewing receipts.","url":"https://insights.sbomify.com/CVE-2025-68147/"}