# CVE-2025-68147: opensourcepos has a Cross-site Scripting vulnerability

> Attackers can inject malicious scripts into the Return Policy field, leading to session hijacking and data theft for users viewing receipts.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** GHSA-xgr7-7pvw-fpmh

## What is CVE-2025-68147?

CVE-2025-68147 is a high-severity cross-site scripting vulnerability in opensourcepos, published on 17 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. Starting in version 3.4.0 and prior to version 3.4.2, a Stored Cross-Site Scripting (XSS) vulnerability exists in the "Return Policy" configuration field. The application does not properly sanitize user input before saving it to the database or displaying it on receipts. An attacker with access to the "Store Configuration" (such as a rogue administrator or an account compromised via the separate CSRF vulnerability) can inject malicious JavaScript payloads into this field. These payloads are executed in the browser of any user (including other administrators and sales staff) whenever they view a receipt or complete a transaction. This can lead to session hijacking, theft of sensitive data, or unauthorized actions performed on behalf of the victim. The vulnerability has been patched in version 3.4.2 by ensuring the output is escaped using the `esc()` function in the receipt template. As a temporary mitigation, administrators should ensure the "Return Policy" field contains only plain text and strictly avoid entering any HTML tags. There is no code-based workaround other than applying the patch.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-68147?

It affects 1 product.


Products: Opensourcepos Open Source Point of Sale.

## How do I fix CVE-2025-68147?

No fix has been published for CVE-2025-68147 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-68147 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68147 exists.

Public exploit code:

- PoC repository for CVE-2025-68147: Stored Cross-Site Scripting (XSS) in OpenSourcePOS. Vulnerability allows privilege escalation via malicious JavaScript injection in the Store Config module. Includes payload details and patch verification (v3.4.0). Security Researcher: Aditya Singh (Nixon-H). (github_poc): https://github.com/Nixon-H/CVE-2025-68147-OSPOS-Stored-XSS

## Other vulnerabilities in opensourcepos

- [CVE-2026-32888](https://insights.sbomify.com/CVE-2026-32888/): Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality (high 8.8)
- [CVE-2026-26746](https://insights.sbomify.com/CVE-2026-26746/): Path traversal in n/a (high 8.8)
- [CVE-2025-68434](https://insights.sbomify.com/CVE-2025-68434/): opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation (high 8.8)
- [CVE-2025-63800](https://insights.sbomify.com/CVE-2025-63800/): Auth bypass in n/a (high 7.5)
- [CVE-2025-70093](https://insights.sbomify.com/CVE-2025-70093/): Command injection in n/a (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68147 and fix it if it is affected.

What it is: CVE-2025-68147 is a high-severity cross-site scripting vulnerability in opensourcepos, published on 17 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68147 exists.

Affected product: opensourcepos. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68147/ (Markdown: https://insights.sbomify.com/CVE-2025-68147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68147
- OSV: https://osv.dev/vulnerability/CVE-2025-68147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68147/
Summaries are generated and may contain mistakes; the official description above is the record.
