CVE-2025-68148 FreshRSS globally denies access to feed via proxy modifying to 429 Retry-After

Medium 4.3 Published Updated

Attackers can deny service to FreshRSS users by manipulating proxy responses to trigger rate limits on feed access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-68148?

CVE-2025-68148 is a medium-severity denial of service vulnerability in FreshRSS, published on 26 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

FreshRSS is a free, self-hostable RSS aggregator. From version 1.27.0 to before 1.28.0, An attacker could globally deny access to feeds via proxy modifying to 429 Retry-After for a large list of feeds on given instance, making it unusable for majority of users. This issue has been patched in version 1.28.0.

Weakness: CWE-770

Which versions are affected by CVE-2025-68148?

It affects 1 product.

Products include Freshrss Freshrss.

How do I fix CVE-2025-68148?

No fix has been published for CVE-2025-68148 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-68148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68148 exists.

Sources

Also known as GHSA-qw34-frg7-gf78.

Is CVE-2025-68148 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free