CVE-2025-68150 Parse Server has Server-Side Request Forgery (SSRF) in Instagram OAuth Adapter
Attackers can exploit SSRF in the Instagram OAuth adapter to bypass authentication or access internal resources by specifying a malicious API URL.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68150?
CVE-2025-68150 is a high-severity server-side request forgery vulnerability in Parseplatform Parse-Server, published on 16 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.2 and 9.1.1-alpha.1, the Instagram authentication adapter allows clients to specify a custom API URL via the `apiURL` parameter in `authData`. This enables SSRF attacks and possibly authentication bypass if malicious endpoints return fake responses to validate unauthorized users. This is fixed in versions 8.6.2 and 9.1.1-alpha.1 by hardcoding the Instagram Graph API URL `https://graph.instagram.com` and ignoring client-provided `apiURL` values. No known workarounds are available.
Weakness: CWE-918
Which versions are affected by CVE-2025-68150?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.2 |
parse-server npm | All versions | 8.6.2 |
parse-server npm | From 9.0.0 | 9.1.1-alpha.1 |
parse-server npm | From 9.0.0 | 9.1.1-alpha.1 |
parse Bitnami | All versions | 8.6.2, 9.1.1 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2025-68150?
Upgrade parse-server to a fixed version for your release line: 8.6.2 or 9.1.1-alpha.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-68150 being exploited?
There is no known exploitation of CVE-2025-68150 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2025-68150, GHSA-3f5f-xgrj-97pf.