# CVE-2025-68151: CoreDNS gRPC/HTTPS/HTTP3 servers lack resource limits, enabling DoS via unbounded connections and oversized messages

> Unauthenticated attackers can crash CoreDNS servers by exhausting resources via unbounded connections or oversized messages in gRPC, HTTPS, and HTTP/3 protocols.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2026
- **Updated:** 8 Jan 2026
- **Also known as:** AZL-73850, AZL-74025, CLEANSTART-2026-DK58903, CLEANSTART-2026-UC13907, ECHO-f181-da3d-daf3, GHSA-527x-5wrf-22m2, GO-2026-4289, MINI-247j-g9rr-h5f4, MINI-2fw3-4v3q-mx68, MINI-49jr-pgx4-jv9h, MINI-5cgp-c4cv-qpx5, MINI-5v2g-4jwg-rc67, MINI-7248-5gfc-x5h2, MINI-84gj-mvx2-jvg6, MINI-89gh-qpch-3fg9, MINI-9chx-3fgm-5jmv, MINI-9r4g-ffj9-j97h, MINI-c3w6-xfw8-pv5x, MINI-fg45-r4wc-23rw, MINI-r424-48gh-7444, MINI-wcmm-pfj3-pqhv, MINI-x9jh-xm4x-frx8, MINI-xj96-684p-h9cv, MINI-xp85-6cgq-68rj, MINI-xxr5-35pc-366q, OESA-2026-3063

## What is CVE-2025-68151?

CVE-2025-68151 is a medium-severity denial of service vulnerability in coredns, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CoreDNS is a DNS server that chains plugins. Prior to version 1.14.0, multiple CoreDNS server implementations (gRPC, HTTPS, and HTTP/3) lack critical resource-limiting controls. An unauthenticated remote attacker can exhaust memory and degrade or crash the server by opening many concurrent connections, streams, or sending oversized request bodies. The issue is similar in nature to CVE-2025-47950 (QUIC DoS) but affects additional server types that do not enforce connection limits, stream limits, or message size constraints. Version 1.14.0 contains a patch.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-68151?

3 open source packages ship an affected version, including github.com/coredns/coredns. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coredns/coredns` | Go | All versions | 1.14.0 |
| `github.com/coredns/coredns` | Go | All versions | 1.14.0 |
| `github.com/coredns/coredns` | Go | All versions | 1.14.0 |

Products: Coredns.io Coredns.

## How do I fix CVE-2025-68151?

Upgrade github.com/coredns/coredns to 1.14.0 or later.

## Is CVE-2025-68151 being exploited?

There is no known exploitation of CVE-2025-68151 in the wild and no public exploit code.

## Other vulnerabilities in coredns

- [CVE-2026-32934](https://insights.sbomify.com/CVE-2026-32934/): CoreDNS DNS-over-QUIC unbounded goroutine growth leads to denial of service (high 8.7)
- [CVE-2026-32936](https://insights.sbomify.com/CVE-2026-32936/): CoreDNS DoH GET path missing size validation causes CPU and memory amplification (high 8.7)
- [CVE-2026-33190](https://insights.sbomify.com/CVE-2026-33190/): CoreDNS TSIG authentication bypass on encrypted DNS transports (high 8.7)
- [CVE-2026-33489](https://insights.sbomify.com/CVE-2026-33489/): CoreDNS transfer plugin subzone ACL bypass via lexicographic zone comparison (high 8.2)
- [CVE-2026-35579](https://insights.sbomify.com/CVE-2026-35579/): CoreDNS TSIG authentication bypass on gRPC, QUIC, DoH, and DoH3 transports (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68151 and fix it if it is affected.

What it is: CVE-2025-68151 is a medium-severity denial of service vulnerability in coredns, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68151 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.0
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.0
- github.com/coredns/coredns (Go): affected all versions; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68151/ (Markdown: https://insights.sbomify.com/CVE-2025-68151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68151
- OSV: https://osv.dev/vulnerability/CVE-2025-68151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68151/
Summaries are generated and may contain mistakes; the official description above is the record.
