# CVE-2025-68154: Command Injection in fsSize() on Windows

> Attackers can execute arbitrary commands on Windows systems if user-controlled input is passed to the fsSize function in the systeminformation library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2025
- **Updated:** 17 Dec 2025
- **Also known as:** CLEANSTART-2026-GO62843, DEBIAN-CVE-2025-68154, GHSA-wphj-fx3q-84ch, MINI-8m8r-p65r-6fxp, MINI-9r3c-wxqg-f8x7, MINI-fj7m-2v9p-2xpf, MINI-mvqh-hwcc-2qhx, MINI-q428-9985-56fw, MINI-q6xj-v5f5-jhxq, MINI-w69p-6533-cqwx, MINI-x557-6mm7-58w5, ROOT-APP-NPM-CVE-2025-68154, UBUNTU-CVE-2025-68154

## What is CVE-2025-68154?

CVE-2025-68154 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

systeminformation is a System and OS information library for node.js. In versions prior to 5.27.14, the `fsSize()` function in systeminformation is vulnerable to OS command injection on Windows systems. The optional `drive` parameter is directly concatenated into a PowerShell command without sanitization, allowing arbitrary command execution when user-controlled input reaches this function. The actual exploitability depends on how applications use this function. If an application does not pass user-controlled input to `fsSize()`, it is not vulnerable. Version 5.27.14 contains a patch.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-68154?

2 open source packages ship an affected version, including systeminformation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `systeminformation` | npm | All versions | 5.27.14 |
| `systeminformation` | npm | All versions | 5.27.14 |

Products: Systeminformation Systeminformation.

## How do I fix CVE-2025-68154?

Upgrade systeminformation to 5.27.14 or later.

## Is CVE-2025-68154 being exploited?

There is no known exploitation of CVE-2025-68154 in the wild and no public exploit code.

## Other vulnerabilities in sebhildebrandt systeminformation

- [CVE-2023-42810](https://insights.sbomify.com/CVE-2023-42810/): systeminformation SSID Command Injection Vulnerability (critical 9.8)
- [CVE-2021-21388](https://insights.sbomify.com/CVE-2021-21388/): Command Injection Vulnerability in systeminformation (high 8.9)
- [CVE-2026-26318](https://insights.sbomify.com/CVE-2026-26318/): systeminformation has Command Injection via Unsanitized `locate` Output in `versions()` (high 8.8)
- [CVE-2020-7752](https://insights.sbomify.com/CVE-2020-7752/): Command Injection (high 8.8)
- [CVE-2026-50289](https://insights.sbomify.com/CVE-2026-50289/): systeminformation: OS command injection in networkInterfaces() via interfaces(5) source-directive path on Linux (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68154 and fix it if it is affected.

What it is: CVE-2025-68154 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68154 in the wild and no public exploit code.

Affected packages and fixed versions:
- systeminformation (npm): affected all versions; fixed in 5.27.14
- systeminformation (npm): affected all versions; fixed in 5.27.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68154/ (Markdown: https://insights.sbomify.com/CVE-2025-68154/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68154
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68154
- OSV: https://osv.dev/vulnerability/CVE-2025-68154

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68154/
Summaries are generated and may contain mistakes; the official description above is the record.
