CVE-2025-68156 Expr has Denial of Service via Unbounded Recursion in Builtin Functions

High 7.5 Published Updated

Attackers can crash applications using the Expr Go library by providing deeply nested or cyclic data to specific builtin functions, causing stack overflow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-68156?

CVE-2025-68156 is a high-severity denial of service vulnerability in expr-lang expr, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Expr is an expression language and expression evaluation for Go. Prior to version 1.17.7, several builtin functions in Expr, including `flatten`, `min`, `max`, `mean`, and `median`, perform recursive traversal over user-provided data structures without enforcing a maximum recursion depth. If the evaluation environment contains deeply nested or cyclic data structures, these functions may recurse indefinitely until exceed the Go runtime stack limit. This results in a stack overflow panic, causing the host application to crash. While exploitability depends on whether an attacker can influence or inject cyclic or pathologically deep data into the evaluation environment, this behavior represents a denial-of-service (DoS) risk and affects overall library robustness. Instead of returning a recoverable evaluation error, the process may terminate unexpectedly. In affected versions, evaluation of expressions that invoke certain builtin functions on untrusted or insufficiently validated data structures can lead to a process-level crash due to stack exhaustion. This issue is most relevant in scenarios where Expr is used to evaluate expressions against externally supplied or dynamically constructed environments; cyclic references (directly or indirectly) can be introduced into arrays, maps, or structs; and there are no application-level safeguards preventing deeply nested input data. In typical use cases with controlled, acyclic data, the issue may not manifest. However, when present, the resulting panic can be used to reliably crash the application, constituting a denial of service. The issue has been fixed in the v1.17.7 versions of Expr. The patch introduces a maximum recursion depth limit for affected builtin functions. When this limit is exceeded, evaluation aborts gracefully and returns a descriptive error instead of panicking. Additionally, the maximum depth can be customized by users via `builtin.MaxDepth`, allowing applications with legitimate deep structures to raise the limit in a controlled manner. Users are strongly encouraged to upgrade to the patched release, which includes both the recursion guard and comprehensive test coverage to prevent regressions. For users who cannot immediately upgrade, some mitigations are recommended. Ensure that evaluation environments cannot contain cyclic references, validate or sanitize externally supplied data structures before passing them to Expr, and/or wrap expression evaluation with panic recovery to prevent a full process crash (as a last-resort defensive measure). These workarounds reduce risk but do not fully eliminate the issue without the patch.

Weakness: CWE-770

Which versions are affected by CVE-2025-68156?

3 open source packages ship an affected version, including github.com/expr-lang/expr. It affects 1 product.

PackageAffectedFixed in
github.com/expr-lang/expr GoAll versions1.17.7
github.com/expr-lang/expr GoAll versions1.17.7
github.com/expr-lang/expr GoAll versions1.17.7
Linux distribution packages (14)
opentelemetry-collector AlmaLinux:10All versions0.135.0-2.el10_1
opentelemetry-collector AlmaLinux:9All versions0.135.0-2.el9_7
opentelemetry-collector Red Hat:enterprise_linux:10.1All versions0:0.135.0-2.el10_1
opentelemetry-collector Red Hat:enterprise_linux:9::appstreamAll versions0:0.135.0-2.el9_7
opentelemetry-collector Red Hat:enterprise_linux_eus:10.0All versions0:0.135.0-2.el10_0
opentelemetry-collector Red Hat:rhel_eus:9.4::appstreamAll versions0:0.135.0-2.el9_4
opentelemetry-collector Red Hat:rhel_eus:9.6::appstreamAll versions0:0.135.0-2.el9_6
opentelemetry-collector Rocky Linux:10All versions0:0.135.0-2.el10_1
opentelemetry-collector Rocky Linux:9All versions0:0.135.0-2.el9_7
coredns openSUSE:TumbleweedAll versions1.14.0-1.1
coredns-for-k8s1.33 openSUSE:TumbleweedAll versions1.12.0-2.1
coredns-for-k8s1.34 openSUSE:TumbleweedAll versions1.12.1-2.1
coredns-for-k8s1.35 openSUSE:TumbleweedAll versions1.13.1-2.1
grafana openSUSE:TumbleweedAll versions11.6.7-2.1

Products include Expr-Lang Expr.

How do I fix CVE-2025-68156?

Upgrade github.com/expr-lang/expr to 1.17.7 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-68156 being exploited?

There is no known exploitation of CVE-2025-68156 in the wild and no public exploit code.

Sources

Also known as ALSA-2025:23664, ALSA-2025:23729, AZL-72727, AZL-72733, AZL-72736, CLEANSTART-2026-CH78548 and 72 more.

Is CVE-2025-68156 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free