CVE-2025-68161 Apache Log4j Core: Missing TLS hostname verification in Socket appender
Man-in-the-middle attackers can intercept or redirect log traffic due to missing TLS hostname verification in the Socket Appender.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68161?
CVE-2025-68161 is a medium-severity vulnerability in Apache Log4j Core, published on 18 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Socket Appender in Apache Log4j Core versions 2.0-beta9 through 2.25.2 does not perform TLS hostname verification of the peer certificate, even when the verifyHostName https://logging.apache.org/log4j/2.x/manual/appenders/network.html#SslConfiguration-attr-verifyHostName configuration attribute or the log4j2.sslVerifyHostName https://logging.apache.org/log4j/2.x/manual/systemproperties.html#log4j2.sslVerifyHostName system property is set to true.
This issue may allow a man-in-the-middle attacker to intercept or redirect log traffic under the following conditions:
* The attacker is able to intercept or redirect network traffic between the client and the log receiver. * The attacker can present a server certificate issued by a certification authority trusted by the Socket Appender’s configured trust store (or by the default Java trust store if no custom trust store is configured).
Users are advised to upgrade to Apache Log4j Core version 2.25.3, which addresses this issue.
As an alternative mitigation, the Socket Appender may be configured to use a private or restricted trust root to limit the set of trusted certificates.
Which versions are affected by CVE-2025-68161?
2 open source packages ship an affected version, including org.apache.logging.log4j:log4j-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.logging.log4j:log4j-core Maven | From 2.0-beta9 | 2.25.3 |
org.apache.logging.log4j:log4j-core Maven | From 2.0-beta9 | 2.25.3 |
Linux distribution packages (3)
log4j SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 2.20.0-150200.4.30.1 |
log4j openSUSE:Leap 15.6 | All versions | 2.20.0-150200.4.30.1 |
log4j openSUSE:Tumbleweed | All versions | 2.20.0-1.1 |
Products include Apache Log4j.
How do I fix CVE-2025-68161?
Upgrade org.apache.logging.log4j:log4j-core to 2.25.3 or later.
Is CVE-2025-68161 being exploited?
There is no known exploitation of CVE-2025-68161 in the wild and no public exploit code.
Other vulnerabilities in Apache Log4j Core
- CVE-2021-44228 Apache Log4j2 Remote Code Execution
- CVE-2021-45046 Apache Log4j2 Deserialization of Untrusted Data
- CVE-2022-23305 SQL injection in JDBC Appender in Apache Log4j V1
- CVE-2017-5645 Deserialization of Untrusted Data in Log4j
- CVE-2022-23302 Deserialization of untrusted data in JMSSink in Apache Log4j 1.x
Sources
Also known as CLEANSTART-2026-AT67837, CLEANSTART-2026-FS24569, CLEANSTART-2026-MW42084, CLEANSTART-2026-NM32016, CLSA-2026-1779842948, CLSA-2026-1781052749 and 78 more.