{"answers":{"affected":"2 open source packages ship an affected version, including openc3.","exploited":"There is no known exploitation of CVE-2025-68271 in the wild and no public exploit code.","fix":"Upgrade openc3 to 6.10.2 or later.","what":"CVE-2025-68271 is a critical code injection vulnerability in OpenC3 cosmos, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-68271 and fix it if it is affected.\n\nWhat it is: CVE-2025-68271 is a critical code injection vulnerability in OpenC3 cosmos, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-68271 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openc3 (RubyGems): affected from 5.0.6; fixed in 6.10.2\n- openc3 (RubyGems): affected from 5.0.6; fixed in 6.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68271/ (Markdown: https://insights.sbomify.com/CVE-2025-68271/index.md)","id":"CVE-2025-68271","markdown":"https://insights.sbomify.com/CVE-2025-68271/index.md","name":"CVE-2025-68271","record":{"aliases":["GHSA-w757-4qv9-mghp"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenC3 COSMOS API","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary Ruby code via the JSON-RPC API due to unsafe eval usage before authorization checks.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. From 5.0.0 to 6.10.1, OpenC3 COSMOS contains a critical remote code execution vulnerability reachable through the JSON-RPC API. When a JSON-RPC request uses the string form of certain APIs, attacker-controlled parameter text is parsed into values using String#convert_to_value. For array-like inputs, convert_to_value executes eval(). Because the cmd code path parses the command string before calling authorize(), an unauthenticated attacker can trigger Ruby code execution even though the request ultimately fails authorization (401). This vulnerability is fixed in 6.10.2.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unauthenticated Remote Code Execution in openc3-api","id":"CVE-2025-68271","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Signal K Server Vulnerable to Denial of Service via Unrestricted Access Request Flooding","id":"CVE-2025-68272"},"packages":[{"ecosystem":"RubyGems","fixed":["6.10.2"],"introduced":["5.0.6"],"last_affected":[],"package":"openc3","purl":null,"source":"GHSA-w757-4qv9-mghp"},{"ecosystem":"RubyGems","fixed":["6.10.2"],"introduced":["5.0.6"],"last_affected":[],"package":"openc3","purl":"pkg:gem/openc3","source":"GHSA-w757-4qv9-mghp"}],"prev":{"headline":"CourseLimitedStaff Role Allows Studio Access","id":"CVE-2025-68270"},"products":["cosmos"],"published":"2026-01-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-13","vendors":["OpenC3"]},"summary":"Unauthenticated attackers can execute arbitrary Ruby code via the JSON-RPC API due to unsafe eval usage before authorization checks.","url":"https://insights.sbomify.com/CVE-2025-68271/"}