# CVE-2025-68271: Unauthenticated Remote Code Execution in openc3-api

> Unauthenticated attackers can execute arbitrary Ruby code via the JSON-RPC API due to unsafe eval usage before authorization checks.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2026
- **Updated:** 13 Jan 2026
- **Also known as:** GHSA-w757-4qv9-mghp

## What is CVE-2025-68271?

CVE-2025-68271 is a critical code injection vulnerability in OpenC3 cosmos, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. From 5.0.0 to 6.10.1, OpenC3 COSMOS contains a critical remote code execution vulnerability reachable through the JSON-RPC API. When a JSON-RPC request uses the string form of certain APIs, attacker-controlled parameter text is parsed into values using String#convert_to_value. For array-like inputs, convert_to_value executes eval(). Because the cmd code path parses the command string before calling authorize(), an unauthenticated attacker can trigger Ruby code execution even though the request ultimately fails authorization (401). This vulnerability is fixed in 6.10.2.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2025-68271?

2 open source packages ship an affected version, including openc3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openc3` | RubyGems | From 5.0.6 | 6.10.2 |
| `openc3` | RubyGems | From 5.0.6 | 6.10.2 |

## How do I fix CVE-2025-68271?

Upgrade openc3 to 6.10.2 or later.

## Is CVE-2025-68271 being exploited?

There is no known exploitation of CVE-2025-68271 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68271 and fix it if it is affected.

What it is: CVE-2025-68271 is a critical code injection vulnerability in OpenC3 cosmos, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68271 in the wild and no public exploit code.

Affected packages and fixed versions:
- openc3 (RubyGems): affected from 5.0.6; fixed in 6.10.2
- openc3 (RubyGems): affected from 5.0.6; fixed in 6.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68271/ (Markdown: https://insights.sbomify.com/CVE-2025-68271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68271
- OSV: https://osv.dev/vulnerability/CVE-2025-68271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68271/
Summaries are generated and may contain mistakes; the official description above is the record.
