# CVE-2025-68279: Weblate has an arbitrary file read via symbolic links

> Attackers can read arbitrary server files via crafted symbolic links in repositories, affecting Weblate users.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2025
- **Updated:** 19 Dec 2025
- **Also known as:** GHSA-g925-f788-4jh7, PYSEC-2026-2040

## What is CVE-2025-68279?

CVE-2025-68279 is a high-severity path traversal vulnerability in WeblateOrg weblate, published on 18 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weblate is a web based localization tool. In versions prior to 5.15.1, it was possible to read arbitrary files from the server file system using crafted symbolic links in the repository. Version 5.15.1 fixes the issue.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-68279?

3 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.15.1 |
| `weblate` | PyPI | All versions | 5.15.1 |
| `Weblate` | PyPI | All versions | 5.15.1 |

Products: Weblate Weblate.

## How do I fix CVE-2025-68279?

Upgrade weblate to 5.15.1 or later.

## Is CVE-2025-68279 being exploited?

There is no known exploitation of CVE-2025-68279 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2022-23915](https://insights.sbomify.com/CVE-2022-23915/): Remote Code Execution (RCE) (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68279 and fix it if it is affected.

What it is: CVE-2025-68279 is a high-severity path traversal vulnerability in WeblateOrg weblate, published on 18 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68279 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.15.1
- weblate (PyPI): affected all versions; fixed in 5.15.1
- Weblate (PyPI): affected all versions; fixed in 5.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68279/ (Markdown: https://insights.sbomify.com/CVE-2025-68279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68279
- OSV: https://osv.dev/vulnerability/CVE-2025-68279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68279/
Summaries are generated and may contain mistakes; the official description above is the record.
