CVE-2025-68280 Apache SIS: XML External Entity (XXE) vulnerability
An attacker can read local server files by crafting malicious XML inputs processed by Apache SIS, affecting geospatial data parsing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-68280?
CVE-2025-68280 is a medium-severity vulnerability in Apache SIS, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Restriction of XML External Entity Reference vulnerability in Apache SIS.
It is possible to write XML files in such a way that, when parsed by Apache SIS, an XML file reveals to the attacker the content of a local file on the server running Apache SIS. This vulnerability impacts the following SIS services:
* Reading of GeoTIFF files having the GEO_METADATA tag defined by the Defense Geospatial Information Working Group (DGIWG).
* Parsing of ISO 19115 metadata in XML format.
* Parsing of Coordinate Reference Systems defined in the GML format.
* Parsing of files in GPS Exchange Format (GPX).
This issue affects Apache SIS from versions 0.4 through 1.5 inclusive. Users are recommended to upgrade to version 1.6, which will fix the issue. In the meantime, the security vulnerability can be avoided by launching Java with the javax.xml.accessExternalDTD system property sets to a comma-separated list of authorized protocols. For example:
java -Djavax.xml.accessExternalDTD="" ...
Weakness: CWE-611
Which versions are affected by CVE-2025-68280?
2 open source packages ship an affected version, including org.apache.sis.core:sis-metadata. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.sis.core:sis-metadata Maven | From 0.4 | 1.6 |
org.apache.sis.core:sis-metadata Maven | From 0.4 | 1.6 |
Products include Apache Spatial Information System.
How do I fix CVE-2025-68280?
Upgrade org.apache.sis.core:sis-metadata to 1.6 or later.
Is CVE-2025-68280 being exploited?
There is no known exploitation of CVE-2025-68280 in the wild and no public exploit code.
Sources
Also known as GHSA-jqmr-2pg9-vfx7.