# CVE-2025-68383: Filebeat Improper Validation of Specified Index, Position, or Offset in Input

> Attackers can crash Filebeat via malformed Syslog messages or malicious Dissect patterns, requiring administrators to upgrade the software.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2025
- **Updated:** 19 Dec 2025
- **Also known as:** GHSA-2mj3-6grc-px38, GO-2025-4252, MINI-44j9-47vc-mghf, MINI-545j-r8j5-qqpj, MINI-5g27-5jv7-cg9j, MINI-79cm-7mq3-3qh9, MINI-7c6c-5v66-hq2j, MINI-9fxr-823c-hpr3, MINI-cf3f-f958-73px, MINI-jv6m-288w-pg8w, MINI-mmw8-7ch2-5cp8, MINI-xg34-7rvq-2r7r

## What is CVE-2025-68383?

CVE-2025-68383 is a medium-severity denial of service vulnerability in Elastic Filebeat, published on 18 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Improper Validation of Specified Index, Position, or Offset in Input (CWE-1285) in Filebeat Syslog parser and the Libbeat Dissect processor can allow a user to trigger a Buffer Overflow (CAPEC-100) and cause a denial of service (panic/crash) of the Filebeat process via either a malformed Syslog message or a malicious tokenizer pattern in the Dissect configuration.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2025-68383?

12 open source packages ship an affected version, including github.com/elastic/beats/v7 and github.com/elastic/beats. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/elastic/beats/v7` | Go | All versions | 7.0.0-alpha2.0.20251204214633-dd3af18220bf |
| `github.com/elastic/beats/v7` | Go | All versions | 7.0.0-alpha2.0.20251204214633-dd3af18220bf |
| `github.com/elastic/beats/v7` | Go | All versions | 7.0.0-alpha2.0.20251204214633-dd3af18220bf |
| `github.com/elastic/beats/v7` | Go | From 7.7.0 | 8.19.9 |
| `github.com/elastic/beats/v7` | Go | From 7.7.0 | 8.19.9 |
| `github.com/elastic/beats/v7` | Go | From 9.0.0 | 9.1.9 |
| `github.com/elastic/beats/v7` | Go | From 9.0.0 | 9.1.9 |
| `github.com/elastic/beats/v7` | Go | From 9.2.0 | 9.2.3 |
| `github.com/elastic/beats/v7` | Go | From 9.2.0 | 9.2.3 |
| `github.com/elastic/beats` | Go | All versions | None |
| `github.com/elastic/beats` | Go | All versions to 7.6.2 | None |
| `github.com/elastic/beats` | Go | All versions to 7.6.2 | None |

Products: Elastic Filebeat.

## How do I fix CVE-2025-68383?

Upgrade github.com/elastic/beats/v7 to a fixed version for your release line: 7.0.0-alpha2.0.20251204214633-dd3af18220bf, 8.19.9, 9.1.9 or 9.2.3.

## Is CVE-2025-68383 being exploited?

There is no known exploitation of CVE-2025-68383 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Filebeat

- [CVE-2026-78588](https://insights.sbomify.com/CVE-2026-78588/): Allocation of Resources Without Limits or Throttling in Filebeat Leading to Denial of Service (medium 6.5)
- [CVE-2023-31413](https://insights.sbomify.com/CVE-2023-31413/): Information disclosure in Filebeat (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68383 and fix it if it is affected.

What it is: CVE-2025-68383 is a medium-severity denial of service vulnerability in Elastic Filebeat, published on 18 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68383 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/elastic/beats/v7 (Go): affected all versions; fixed in 7.0.0-alpha2.0.20251204214633-dd3af18220bf
- github.com/elastic/beats/v7 (Go): affected all versions; fixed in 7.0.0-alpha2.0.20251204214633-dd3af18220bf
- github.com/elastic/beats/v7 (Go): affected all versions; fixed in 7.0.0-alpha2.0.20251204214633-dd3af18220bf
- github.com/elastic/beats/v7 (Go): affected from 7.7.0; fixed in 8.19.9
- github.com/elastic/beats/v7 (Go): affected from 7.7.0; fixed in 8.19.9
- github.com/elastic/beats/v7 (Go): affected from 9.0.0; fixed in 9.1.9
- github.com/elastic/beats/v7 (Go): affected from 9.0.0; fixed in 9.1.9
- github.com/elastic/beats/v7 (Go): affected from 9.2.0; fixed in 9.2.3
- github.com/elastic/beats/v7 (Go): affected from 9.2.0; fixed in 9.2.3
- github.com/elastic/beats (Go): affected all versions; no fix listed
- github.com/elastic/beats (Go): affected all versions up to 7.6.2; no fix listed
- github.com/elastic/beats (Go): affected all versions up to 7.6.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68383/ (Markdown: https://insights.sbomify.com/CVE-2025-68383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68383
- OSV: https://osv.dev/vulnerability/CVE-2025-68383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68383/
Summaries are generated and may contain mistakes; the official description above is the record.
