# CVE-2025-68428: jsPDF has Local File Inclusion/Path Traversal vulnerability

> Attackers can read arbitrary local files via path traversal in jsPDF's Node.js build, exposing sensitive data in generated PDFs.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 7 Sep 2026
- **Also known as:** CLSA-2026-1773447390, CLSA-2026-1773620208, GHSA-f8cm-6447-x5h2, ROOT-APP-NPM-CVE-2025-68428

## What is CVE-2025-68428?

CVE-2025-68428 is a critical path traversal vulnerability in parallax jsPDF, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jsPDF is a library to generate PDFs in JavaScript. Prior to version 4.0.0, user control of the first argument of the loadFile method in the node.js build allows local file inclusion/path traversal. If given the possibility to pass unsanitized paths to the loadFile method, a user can retrieve file contents of arbitrary files in the local file system the node process is running in. The file contents are included verbatim in the generated PDFs. Other affected methods are `addImage`, `html`, and `addFont`. Only the node.js builds of the library are affected, namely the `dist/jspdf.node.js` and `dist/jspdf.node.min.js` files. The vulnerability has been fixed in jsPDF@4.0.0. This version restricts file system access per default. This semver-major update does not introduce other breaking changes. Some workarounds areavailable. With recent node versions, jsPDF recommends using the `--permission` flag in production. The feature was introduced experimentally in v20.0.0 and is stable since v22.13.0/v23.5.0/v24.0.0. For older node versions, sanitize user-provided paths before passing them to jsPDF.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-73 (External Control of File Name or Path), CWE-35 (Path Traversal: '.../...//')

## Which versions are affected by CVE-2025-68428?

2 open source packages ship an affected version, including jspdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jspdf` | npm | All versions | 4.0.0 |
| `jspdf` | npm | All versions | 4.0.0 |

Products: Parall Jspdf.

## How do I fix CVE-2025-68428?

Upgrade jspdf to 4.0.0 or later.

## Is CVE-2025-68428 being exploited?

There is no known exploitation of CVE-2025-68428 in the wild and no public exploit code.

Public exploit code:

-  CVE-2025-68428 Proof of Concept (github_poc): https://github.com/12nio/CVE-2025-68428_PoC
- Asset-wide detection tool for identifying jsPDF usage related to CVE-2025-68428 Detection only — no exploitation (github_poc): https://github.com/Nurjaman2004/jsPDF-Bulk-Detector-CVE-2025-68428-

## Other vulnerabilities in parallax jsPDF

- [CVE-2026-31938](https://insights.sbomify.com/CVE-2026-31938/): jsPDF has HTML Injection in New Window paths (critical 9.6)
- [CVE-2026-25535](https://insights.sbomify.com/CVE-2026-25535/): jsPDF Affected by Client-Side/Server-Side Denial of Service via Malicious GIF Dimensions (high 8.7)
- [CVE-2026-24133](https://insights.sbomify.com/CVE-2026-24133/): jsPDF Affected by Denial of Service (DoS) via Unvalidated BMP Dimensions in BMPDecoder (high 8.7)
- [CVE-2025-57810](https://insights.sbomify.com/CVE-2025-57810/): jsPDF Parsing of Corrupt PNGs Leads to Potential Denial of Service (DoS) (high 8.7)
- [CVE-2025-29907](https://insights.sbomify.com/CVE-2025-29907/): jsPDF Bypass Regular Expression Denial of Service (ReDoS) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68428 and fix it if it is affected.

What it is: CVE-2025-68428 is a critical path traversal vulnerability in parallax jsPDF, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68428 in the wild and no public exploit code.

Affected packages and fixed versions:
- jspdf (npm): affected all versions; fixed in 4.0.0
- jspdf (npm): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68428/ (Markdown: https://insights.sbomify.com/CVE-2025-68428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68428
- OSV: https://osv.dev/vulnerability/CVE-2025-68428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68428/
Summaries are generated and may contain mistakes; the official description above is the record.
