# CVE-2025-68429: Storybook manager bundle may expose environment variables during build

> Attackers can view sensitive environment variables exposed in Storybook build artifacts if a .env file exists during the build process.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** CLSA-2026-1791983867, CLSA-2026-1792160913, CLSA-2026-1792161049, CLSA-2026-1792161051, CLSA-2026-1792161053, CLSA-2026-1792161057, CLSA-2026-1792161059, CLSA-2026-1792161069, CLSA-2026-1792161478, CLSA-2026-1792161763, CLSA-2026-1792161873, CLSA-2026-1792162009, CLSA-2026-1792162055, CLSA-2026-1792162081, CLSA-2026-1792162127, CLSA-2026-1792162170, CLSA-2026-1792162193, CLSA-2026-1792162196, CLSA-2026-1792162199, CLSA-2026-1792162201, CLSA-2026-1792162203, CLSA-2026-1792163459, CLSA-2026-1792192776, CLSA-2026-1792218913, CLSA-2026-1792219253, CLSA-2026-1792220390, CLSA-2026-1792220849, CLSA-2026-1792221334, CLSA-2026-1792221532, CLSA-2026-1792221827, CLSA-2026-1792222163, CLSA-2026-1792222474, CLSA-2026-1792222783, CLSA-2026-1792270009, CLSA-2026-1792301414, CLSA-2026-1792329953, CLSA-2026-1792329954, CLSA-2026-1792352432, CLSA-2026-1792360188, CLSA-2026-1792368197, CLSA-2026-1792372481, CLSA-2026-1792372483, CLSA-2026-1792376835, CLSA-2026-1792380797, CLSA-2026-1792383182, CLSA-2026-1792383183, CLSA-2026-1792386963, CLSA-2026-1792389922, CLSA-2026-1792417348, CLSA-2026-1792418997, CLSA-2026-1792424327, CLSA-2026-1792427473, CLSA-2026-1792429617, CLSA-2026-1792432511, CLSA-2026-1792433315, CLSA-2026-1792435669, CLSA-2026-1792436480, CLSA-2026-1792438531, CLSA-2026-1792439079, CLSA-2026-1792441520, CLSA-2026-1792442135, CLSA-2026-1792442688, CLSA-2026-1792449928, CLSA-2026-1792450473, CLSA-2026-1792453160, CLSA-2026-1792455642, CLSA-2026-1792458250, CLSA-2026-1792458833, CLSA-2026-1792460809, CLSA-2026-1792462295, CLSA-2026-1792466720, CLSA-2026-1792471629, CLSA-2026-1792759924, GHSA-8452-54wp-rmv6, MINI-2hh2-x2gh-f3j2, ROOT-APP-NPM-CVE-2025-68429

## What is CVE-2025-68429?

CVE-2025-68429 is a high-severity vulnerability in storybookjs storybook, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Storybook is a frontend workshop for building user interface components and pages in isolation. A vulnerability present starting in versions 7.0.0 and prior to versions 7.6.21, 8.6.15, 9.1.17, and 10.1.10 relates to Storybook’s handling of environment variables defined in a `.env` file, which could, in specific circumstances, lead to those variables being unexpectedly bundled into the artifacts created by the `storybook build` command. When a built Storybook is published to the web, the bundle’s source is viewable, thus potentially exposing those variables to anyone with access. For a project to potentially be vulnerable to this issue, it must build the Storybook (i.e. run `storybook build` directly or indirectly) in a directory that contains a `.env` file (including variants like `.env.local`) and publish the built Storybook to the web. Storybooks built without a `.env` file at build time are not affected, including common CI-based builds where secrets are provided via platform environment variables rather than `.env` files. Storybook runtime environments (i.e. `storybook dev`) are not affected. Deployed applications that share a repo with your Storybook are not affected. Users should upgrade their Storybook—on both their local machines and CI environment—to version .6.21, 8.6.15, 9.1.17, or 10.1.10 as soon as possible. Maintainers additionally recommend that users audit for any sensitive secrets provided via `.env` files and rotate those keys. Some projects may have been relying on the undocumented behavior at the heart of this issue and will need to change how they reference environment variables after this update. If a project can no longer read necessary environmental variable values, either prefix the variables with `STORYBOOK_` or use the `env` property in Storybook’s configuration to manually specify values. In either case, do not include sensitive secrets as they will be included in the built bundle.

Weakness: CWE-541 (Inclusion of Sensitive Information in an Include File), CWE-538 (Insertion of Sensitive Information into Externally-Accessible File or Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-68429?

8 open source packages ship an affected version, including storybook. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `storybook` | npm | From 10.0.0 | 10.1.10 |
| `storybook` | npm | From 10.0.0 | 10.1.10 |
| `storybook` | npm | From 7.0.0 | 7.6.21 |
| `storybook` | npm | From 7.0.0 | 7.6.21 |
| `storybook` | npm | From 8.0.0 | 8.6.15 |
| `storybook` | npm | From 8.0.0 | 8.6.15 |
| `storybook` | npm | From 9.0.0 | 9.1.17 |
| `storybook` | npm | From 9.0.0 | 9.1.17 |

Products: Storybook Storybook.

## How do I fix CVE-2025-68429?

Upgrade storybook to a fixed version for your release line: 10.1.10, 7.6.21, 8.6.15 or 9.1.17.

## Is CVE-2025-68429 being exploited?

There is no known exploitation of CVE-2025-68429 in the wild and no public exploit code.

## Other vulnerabilities in storybookjs storybook

- [CVE-2026-27148](https://insights.sbomify.com/CVE-2026-27148/): Storybook Dev Server Vulnerable to WebSocket Hijacking (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68429 and fix it if it is affected.

What it is: CVE-2025-68429 is a high-severity vulnerability in storybookjs storybook, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68429 in the wild and no public exploit code.

Affected packages and fixed versions:
- storybook (npm): affected from 10.0.0; fixed in 10.1.10
- storybook (npm): affected from 10.0.0; fixed in 10.1.10
- storybook (npm): affected from 7.0.0; fixed in 7.6.21
- storybook (npm): affected from 7.0.0; fixed in 7.6.21
- storybook (npm): affected from 8.0.0; fixed in 8.6.15
- storybook (npm): affected from 8.0.0; fixed in 8.6.15
- storybook (npm): affected from 9.0.0; fixed in 9.1.17
- storybook (npm): affected from 9.0.0; fixed in 9.1.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68429/ (Markdown: https://insights.sbomify.com/CVE-2025-68429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68429
- OSV: https://osv.dev/vulnerability/CVE-2025-68429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68429/
Summaries are generated and may contain mistakes; the official description above is the record.
