CVE-2025-68434 opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation

High 8.8 Published Updated

An attacker can create an administrator account via CSRF if the protection filter is disabled, leading to full system takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-68434?

CVE-2025-68434 is a high-severity vulnerability in opensourcepos, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. Starting in version 3.4.0 and prior to version 3.4.2, a Cross-Site Request Forgery (CSRF) vulnerability exists in the application's filter configuration. The CSRF protection mechanism was **explicitly disabled**, allowing the application to process state-changing requests (POST) without verifying a valid CSRF token. An unauthenticated remote attacker can exploit this by hosting a malicious web page. If a logged-in administrator visits this page, their browser is forced to send unauthorized requests to the application. A successful exploit allows the attacker to silently create a new Administrator account with full privileges, leading to a complete takeover of the system and loss of confidentiality, integrity, and availability. The vulnerability has been patched in version 3.4.2. The fix re-enables the CSRF filter in `app/Config/Filters.php` and resolves associated AJAX race conditions by adjusting token regeneration settings. As a workaround, administrators can manually re-enable the CSRF filter in `app/Config/Filters.php` by uncommenting the protection line. However, this is not recommended without applying the full patch, as it may cause functionality breakage in the Sales module due to token synchronization issues.

Weakness: CWE-352

Which versions are affected by CVE-2025-68434?

It affects 1 product.

Products include Opensourcepos Open Source Point of Sale.

How do I fix CVE-2025-68434?

No fix has been published for CVE-2025-68434 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-68434 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68434 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-wjm4-hfwg-5w5r.

Is CVE-2025-68434 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free