{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68434 exists.","fix":"No fix has been published for CVE-2025-68434 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-68434 is a high-severity vulnerability in opensourcepos, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-68434 and fix it if it is affected.\n\nWhat it is: CVE-2025-68434 is a high-severity vulnerability in opensourcepos, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68434 exists.\n\nAffected product: opensourcepos. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68434/ (Markdown: https://insights.sbomify.com/CVE-2025-68434/index.md)","id":"CVE-2025-68434","markdown":"https://insights.sbomify.com/CVE-2025-68434/index.md","name":"CVE-2025-68434","record":{"aliases":["GHSA-wjm4-hfwg-5w5r"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Point of Sale application","requires_auth":"none","summary":"An attacker can create an administrator account via CSRF if the protection filter is disabled, leading to full system takeover.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"open_source_point_of_sale","vendor":"opensourcepos"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. Starting in version 3.4.0 and prior to version 3.4.2, a Cross-Site Request Forgery (CSRF) vulnerability exists in the application's filter configuration. The CSRF protection mechanism was **explicitly disabled**, allowing the application to process state-changing requests (POST) without verifying a valid CSRF token. An unauthenticated remote attacker can exploit this by hosting a malicious web page. If a logged-in administrator visits this page, their browser is forced to send unauthorized requests to the application. A successful exploit allows the attacker to silently create a new Administrator account with full privileges, leading to a complete takeover of the system and loss of confidentiality, integrity, and availability. The vulnerability has been patched in version 3.4.2. The fix re-enables the CSRF filter in `app/Config/Filters.php` and resolves associated AJAX race conditions by adjusting token regeneration settings. As a workaround, administrators can manually re-enable the CSRF filter in `app/Config/Filters.php` by uncommenting the protection line. However, this is not recommended without applying the full patch, as it may cause functionality breakage in the Sales module due to token synchronization issues.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-12-17","github_poc":1,"max_poc_stars":3,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-12-17T17:37:18Z","kind":"github_poc","ref":"https://github.com/Nixon-H/CVE-2025-68434-OSPOS-CSRF","stars":3,"title":"PoC \u0026 Write-up for CVE-2025-68434: Critical CSRF in OpenSourcePOS. Exploits a disabled filter configuration to allow unauthenticated attackers to silently create rogue Administrator accounts, leading to full system takeover. Validated on versions \u003c 3.4.0."}],"tier":"weaponised"},"has_fix":false,"headline":"opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation","id":"CVE-2025-68434","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":0,"n_references":4,"next":{"headline":"Zerobyte has Authentication Bypass by Primary Weakness","id":"CVE-2025-68435"},"packages":[],"prev":{"headline":"Zed IDE MCP Context Server Configuration Arbitrary Code Execution","id":"CVE-2025-68433"},"products":["opensourcepos"],"published":"2025-12-17","related":[{"cvss_score":8.8,"headline":"Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality","id":"CVE-2026-32888","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":8.8,"headline":"Path traversal in n/a","id":"CVE-2026-26746","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":8.1,"headline":"opensourcepos has a Cross-site Scripting vulnerability","id":"CVE-2025-68147","kev_date_added":null,"published":"2025-12-17"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2025-63800","kev_date_added":null,"published":"2025-11-18"},{"cvss_score":7.4,"headline":"Command injection in n/a","id":"CVE-2025-70093","kev_date_added":null,"published":"2026-02-13"},{"cvss_score":7.2,"headline":"Cross-site scripting in n/a","id":"CVE-2025-66921","kev_date_added":null,"published":"2025-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-18","vendors":["opensourcepos"]},"summary":"An attacker can create an administrator account via CSRF if the protection filter is disabled, leading to full system takeover.","url":"https://insights.sbomify.com/CVE-2025-68434/"}