# CVE-2025-68434: opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation

> An attacker can create an administrator account via CSRF if the protection filter is disabled, leading to full system takeover.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** GHSA-wjm4-hfwg-5w5r

## What is CVE-2025-68434?

CVE-2025-68434 is a high-severity vulnerability in opensourcepos, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. Starting in version 3.4.0 and prior to version 3.4.2, a Cross-Site Request Forgery (CSRF) vulnerability exists in the application's filter configuration. The CSRF protection mechanism was **explicitly disabled**, allowing the application to process state-changing requests (POST) without verifying a valid CSRF token. An unauthenticated remote attacker can exploit this by hosting a malicious web page. If a logged-in administrator visits this page, their browser is forced to send unauthorized requests to the application. A successful exploit allows the attacker to silently create a new Administrator account with full privileges, leading to a complete takeover of the system and loss of confidentiality, integrity, and availability. The vulnerability has been patched in version 3.4.2. The fix re-enables the CSRF filter in `app/Config/Filters.php` and resolves associated AJAX race conditions by adjusting token regeneration settings. As a workaround, administrators can manually re-enable the CSRF filter in `app/Config/Filters.php` by uncommenting the protection line. However, this is not recommended without applying the full patch, as it may cause functionality breakage in the Sales module due to token synchronization issues.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-68434?

It affects 1 product.


Products: Opensourcepos Open Source Point of Sale.

## How do I fix CVE-2025-68434?

No fix has been published for CVE-2025-68434 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-68434 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68434 exists.

Public exploit code:

- PoC & Write-up for CVE-2025-68434: Critical CSRF in OpenSourcePOS. Exploits a disabled filter configuration to allow unauthenticated attackers to silently create rogue Administrator accounts, leading to full system takeover. Validated on versions < 3.4.0. (github_poc): https://github.com/Nixon-H/CVE-2025-68434-OSPOS-CSRF

## Other vulnerabilities in opensourcepos

- [CVE-2026-32888](https://insights.sbomify.com/CVE-2026-32888/): Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality (high 8.8)
- [CVE-2026-26746](https://insights.sbomify.com/CVE-2026-26746/): Path traversal in n/a (high 8.8)
- [CVE-2025-68147](https://insights.sbomify.com/CVE-2025-68147/): opensourcepos has a Cross-site Scripting vulnerability (high 8.1)
- [CVE-2025-63800](https://insights.sbomify.com/CVE-2025-63800/): Auth bypass in n/a (high 7.5)
- [CVE-2025-70093](https://insights.sbomify.com/CVE-2025-70093/): Command injection in n/a (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68434 and fix it if it is affected.

What it is: CVE-2025-68434 is a high-severity vulnerability in opensourcepos, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68434 exists.

Affected product: opensourcepos. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68434/ (Markdown: https://insights.sbomify.com/CVE-2025-68434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68434
- OSV: https://osv.dev/vulnerability/CVE-2025-68434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68434/
Summaries are generated and may contain mistakes; the official description above is the record.
