CVE-2025-68436 Craft CMS vulnerable to potential information disclosure via unchecked asset relocation
Authenticated users can expose sensitive assets via malicious requests in Craft CMS, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68436?
CVE-2025-68436 is a medium-severity vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16, authenticated users on a Craft installation could potentially expose sensitive assets via their user profile photo via maliciously crafted requests. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.
Weakness: CWE-200
Which versions are affected by CVE-2025-68436?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.16.17 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.16.17 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
Products include Craftcms Craft Cms.
How do I fix CVE-2025-68436?
Upgrade craftcms/cms to a fixed version for your release line: 4.16.17 or 5.8.21.
Is CVE-2025-68436 being exploited?
There is no known exploitation of CVE-2025-68436 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-53vf-c43h-j2x9.