CVE-2025-68437 Craft CMS vulnerable to Server-Side Request Forgery (SSRF) via GraphQL Asset Upload Mutation
Attackers with asset management permissions can exploit SSRF in Craft CMS GraphQL mutations to access internal services and exfiltrate sensitive data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68437?
CVE-2025-68437 is a medium-severity server-side request forgery vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16, the Craft CMS GraphQL `save_<VolumeName>_Asset` mutation is vulnerable to Server-Side Request Forgery (SSRF). This vulnerability arises because the `_file` input, specifically its `url` parameter, allows the server to fetch content from arbitrary remote locations without proper validation. Attackers can exploit this by providing internal IP addresses or cloud metadata endpoints as the `url`, forcing the server to make requests to these restricted services. The fetched content is then saved as an asset, which can subsequently be accessed and exfiltrated, leading to potential data exposure and infrastructure compromise. This exploitation requires specific GraphQL permissions for asset management within the targeted volume. Users should update to the patched 5.8.21 and 4.16.17 releases to mitigate the issue.
Weakness: CWE-918
Which versions are affected by CVE-2025-68437?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 3.5.0 | 4.16.17 |
craftcms/cms Packagist | From 3.5.0 | 4.16.17 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
Products include Craftcms Craft Cms.
How do I fix CVE-2025-68437?
Upgrade craftcms/cms to a fixed version for your release line: 4.16.17 or 5.8.21.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-68437 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68437 exists.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-x27p-wfqw-hfcc.