CVE-2025-68438 Apache Airflow: Secrets in rendered templates could contain parts of sensitive values when truncated

High 7.5 Published Updated

Attackers can view sensitive secrets in cleartext via the Rendered Templates UI if fields exceed length limits, requiring an upgrade to Apache Airflow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-68438?

CVE-2025-68438 is a high-severity vulnerability in Apache Airflow, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display.

Users are recommended to upgrade to 3.1.6 or later, which fixes this issue

Weakness: CWE-200

Which versions are affected by CVE-2025-68438?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 3.1.03.1.6
apache-airflow PyPIFrom 3.1.03.1.6
apache-airflow PyPIFrom 3.1.03.1.6
airflow BitnamiFrom 3.1.03.1.6

Products include Apache Airflow.

How do I fix CVE-2025-68438?

Upgrade apache-airflow to 3.1.6 or later.

Is CVE-2025-68438 being exploited?

There is no known exploitation of CVE-2025-68438 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2025-68438, GHSA-3qmm-r55x-hpxx, MINI-5jgp-gj33-rjxr, PYSEC-2026-9.

Is CVE-2025-68438 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free