{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-68438 in the wild and no public exploit code.","fix":"Upgrade apache-airflow to 3.1.6 or later.","what":"CVE-2025-68438 is a high-severity vulnerability in Apache Airflow, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-68438 and fix it if it is affected.\n\nWhat it is: CVE-2025-68438 is a high-severity vulnerability in Apache Airflow, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-68438 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow (PyPI): affected from 3.1.0; fixed in 3.1.6\n- apache-airflow (PyPI): affected from 3.1.0; fixed in 3.1.6\n- apache-airflow (PyPI): affected from 3.1.0; fixed in 3.1.6\n- airflow (Bitnami): affected from 3.1.0; fixed in 3.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68438/ (Markdown: https://insights.sbomify.com/CVE-2025-68438/index.md)","id":"CVE-2025-68438","markdown":"https://insights.sbomify.com/CVE-2025-68438/index.md","name":"CVE-2025-68438","record":{"aliases":["BIT-airflow-2025-68438","GHSA-3qmm-r55x-hpxx","MINI-5jgp-gj33-rjxr","PYSEC-2026-9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Airflow","requires_auth":"none","summary":"Attackers can view sensitive secrets in cleartext via the Rendered Templates UI if fields exceed length limits, requiring an upgrade to Apache Airflow.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display.\n\nUsers are recommended to upgrade to 3.1.6 or later, which fixes this issue","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow: Secrets in rendered templates could contain parts of sensitive values when truncated","id":"CVE-2025-68438","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:airflow","products":["apache:airflow"],"type":"information_disclosure","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI","id":"CVE-2025-68454"},"packages":[{"ecosystem":"Bitnami","fixed":["3.1.6"],"introduced":["3.1.0"],"last_affected":[],"package":"airflow","purl":"pkg:bitnami/airflow","source":"BIT-airflow-2025-68438"},{"ecosystem":"PyPI","fixed":["3.1.6"],"introduced":["3.1.0"],"last_affected":[],"package":"apache-airflow","purl":null,"source":"GHSA-3qmm-r55x-hpxx"},{"ecosystem":"PyPI","fixed":["3.1.6"],"introduced":["3.1.0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"GHSA-3qmm-r55x-hpxx"},{"ecosystem":"PyPI","fixed":["3.1.6"],"introduced":["3.1.0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2026-9"}],"prev":{"headline":"Craft CMS vulnerable to Server-Side Request Forgery (SSRF) via GraphQL Asset Upload Mutation","id":"CVE-2025-68437"},"products":["Apache Airflow"],"published":"2026-01-16","related":[{"cvss_score":9.8,"headline":"Apache Airflow's Experimental API Authentication Bypass","id":"CVE-2020-13927","kev_date_added":"2022-01-18","published":"2020-11-10"},{"cvss_score":8.8,"headline":"Apache Airflow Command Injection","id":"CVE-2020-11978","kev_date_added":"2022-01-18","published":"2020-07-16"},{"cvss_score":9.8,"headline":"Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()","id":"CVE-2026-33264","kev_date_added":null,"published":"2026-07-07"},{"cvss_score":9.8,"headline":"Apache Airflow: Privilege escalation using airflow logs","id":"CVE-2023-25754","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":9.8,"headline":"Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow","id":"CVE-2023-22884","kev_date_added":null,"published":"2023-01-21"},{"cvss_score":9.8,"headline":"Apache Airflow Pinot provider allowed Command Injection","id":"CVE-2022-38649","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":9.8,"headline":"Apache Airlfow Pig Provider RCE","id":"CVE-2022-40189","kev_date_added":null,"published":"2022-11-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can view sensitive secrets in cleartext via the Rendered Templates UI if fields exceed length limits, requiring an upgrade to Apache Airflow.","url":"https://insights.sbomify.com/CVE-2025-68438/"}