# CVE-2025-68438: Apache Airflow: Secrets in rendered templates could contain parts of sensitive values when truncated

> Attackers can view sensitive secrets in cleartext via the Rendered Templates UI if fields exceed length limits, requiring an upgrade to Apache Airflow.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2026
- **Updated:** 16 Jan 2026
- **Also known as:** BIT-airflow-2025-68438, GHSA-3qmm-r55x-hpxx, MINI-5jgp-gj33-rjxr, PYSEC-2026-9

## What is CVE-2025-68438?

CVE-2025-68438 is a high-severity vulnerability in Apache Airflow, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display.

Users are recommended to upgrade to 3.1.6 or later, which fixes this issue

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-68438?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.1.0 | 3.1.6 |
| `apache-airflow` | PyPI | From 3.1.0 | 3.1.6 |
| `apache-airflow` | PyPI | From 3.1.0 | 3.1.6 |
| `airflow` | Bitnami | From 3.1.0 | 3.1.6 |

Products: Apache Airflow.

## How do I fix CVE-2025-68438?

Upgrade apache-airflow to 3.1.6 or later.

## Is CVE-2025-68438 being exploited?

There is no known exploitation of CVE-2025-68438 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68438 and fix it if it is affected.

What it is: CVE-2025-68438 is a high-severity vulnerability in Apache Airflow, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68438 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.1.0; fixed in 3.1.6
- apache-airflow (PyPI): affected from 3.1.0; fixed in 3.1.6
- apache-airflow (PyPI): affected from 3.1.0; fixed in 3.1.6
- airflow (Bitnami): affected from 3.1.0; fixed in 3.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68438/ (Markdown: https://insights.sbomify.com/CVE-2025-68438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68438
- OSV: https://osv.dev/vulnerability/CVE-2025-68438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68438/
Summaries are generated and may contain mistakes; the official description above is the record.
