CVE-2025-68454 Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI
Authenticated attackers can achieve remote code execution via Twig SSTI in Craft CMS, requiring admin access or specific utility permissions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68454?
CVE-2025-68454 is a medium-severity code injection vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via Twig SSTI. For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled, which is against Craft CMS' recommendations for any non-dev environment. Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig `map` filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.
Weakness: CWE-1336
Which versions are affected by CVE-2025-68454?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.16.17 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.16.17 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
Products include Craftcms Craft Cms.
How do I fix CVE-2025-68454?
Upgrade craftcms/cms to a fixed version for your release line: 4.16.17 or 5.8.21.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-68454 being exploited?
There is no known exploitation of CVE-2025-68454 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as CLSA-2026-1793226310, GHSA-742x-x762-7383.