{"answers":{"affected":"4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-68454 in the wild and no public exploit code.","fix":"Upgrade craftcms/cms to a fixed version for your release line: 4.16.17 or 5.8.21.","what":"CVE-2025-68454 is a medium-severity code injection vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-68454 and fix it if it is affected.\n\nWhat it is: CVE-2025-68454 is a medium-severity code injection vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-68454 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.16.17\n- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.16.17\n- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.21\n- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68454/ (Markdown: https://insights.sbomify.com/CVE-2025-68454/index.md)","id":"CVE-2025-68454","markdown":"https://insights.sbomify.com/CVE-2025-68454/index.md","name":"CVE-2025-68454","record":{"aliases":["CLSA-2026-1793226310","GHSA-742x-x762-7383"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Craft CMS","requires_auth":"low_privilege","summary":"Authenticated attackers can achieve remote code execution via Twig SSTI in Craft CMS, requiring admin access or specific utility permissions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"craft_cms","vendor":"craftcms"}],"cvss":{"score":5.2,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via Twig SSTI. For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled, which is against Craft CMS' recommendations for any non-dev environment. Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig `map` filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI","id":"CVE-2025-68454","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"craftcms:craft_cms","products":["craftcms:craft_cms"],"type":"code_injection","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"Craft CMS vulnerable to potential authenticated Remote Code Execution via malicious attached Behavior","id":"CVE-2025-68455"},"packages":[{"ecosystem":"Packagist","fixed":["4.16.17"],"introduced":["4.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-742x-x762-7383"},{"ecosystem":"Packagist","fixed":["4.16.17"],"introduced":["4.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-742x-x762-7383"},{"ecosystem":"Packagist","fixed":["5.8.21"],"introduced":["5.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-742x-x762-7383"},{"ecosystem":"Packagist","fixed":["5.8.21"],"introduced":["5.0.0-RC1"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-742x-x762-7383"}],"prev":{"headline":"Apache Airflow: Secrets in rendered templates could contain parts of sensitive values when truncated","id":"CVE-2025-68438"},"products":["cms"],"published":"2026-01-05","related":[{"cvss_score":10,"headline":"Craft CMS Code Injection","id":"CVE-2025-32432","kev_date_added":"2026-03-20","published":"2025-04-25"},{"cvss_score":9.3,"headline":"Craft CMS Code Injection","id":"CVE-2024-56145","kev_date_added":"2025-06-02","published":"2024-12-18"},{"cvss_score":8.1,"headline":"Craft CMS Code Injection","id":"CVE-2025-23209","kev_date_added":"2025-02-20","published":"2025-01-18"},{"cvss_score":6.9,"headline":"Craft CMS External Control of Assumed-Immutable Web Parameter","id":"CVE-2025-35939","kev_date_added":"2025-06-02","published":"2025-05-07"},{"cvss_score":10,"headline":"Craft CMS Remote Code Execution vulnerability","id":"CVE-2023-41892","kev_date_added":null,"published":"2023-09-13"},{"cvss_score":9.8,"headline":"Craft CMS Remote Code Injection","id":"CVE-2021-27903","kev_date_added":null,"published":"2021-06-30"},{"cvss_score":9.8,"headline":"SEOmatic for CraftCMS allows Server-Side Template Injection","id":"CVE-2020-9757","kev_date_added":null,"published":"2020-03-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-06","vendors":["craftcms"]},"summary":"Authenticated attackers can achieve remote code execution via Twig SSTI in Craft CMS, requiring admin access or specific utility permissions.","url":"https://insights.sbomify.com/CVE-2025-68454/"}