# CVE-2025-68454: Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI

> Authenticated attackers can achieve remote code execution via Twig SSTI in Craft CMS, requiring admin access or specific utility permissions.

- **Severity:** Medium 5.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 6 Jan 2026
- **Also known as:** CLSA-2026-1793226310, GHSA-742x-x762-7383

## What is CVE-2025-68454?

CVE-2025-68454 is a medium-severity code injection vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via Twig SSTI. For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled, which is against Craft CMS' recommendations for any non-dev environment. Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig `map` filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2025-68454?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.16.17 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.16.17 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.21 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.21 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2025-68454?

Upgrade craftcms/cms to a fixed version for your release line: 4.16.17 or 5.8.21.

## Is CVE-2025-68454 being exploited?

There is no known exploitation of CVE-2025-68454 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68454 and fix it if it is affected.

What it is: CVE-2025-68454 is a medium-severity code injection vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68454 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.16.17
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.16.17
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.21
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68454/ (Markdown: https://insights.sbomify.com/CVE-2025-68454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68454
- OSV: https://osv.dev/vulnerability/CVE-2025-68454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68454/
Summaries are generated and may contain mistakes; the official description above is the record.
