CVE-2025-68455 Craft CMS vulnerable to potential authenticated Remote Code Execution via malicious attached Behavior
An administrator can achieve remote code execution in Craft CMS by attaching a malicious Behavior object.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68455?
CVE-2025-68455 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via malicious attached Behavior. Note that attackers must have administrator access to the Craft Control Panel for this to work. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.
Weakness: CWE-470
Which versions are affected by CVE-2025-68455?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.16.17 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.16.17 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
Products include Craftcms Craft Cms.
How do I fix CVE-2025-68455?
Upgrade craftcms/cms to a fixed version for your release line: 4.16.17 or 5.8.21.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-68455 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68455 exists.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-255j-qw47-wjh5.