CVE-2025-68456 Unauthenticated Craft CMS users can trigger a database backup
Unauthenticated attackers can trigger database backups in Craft CMS, causing resource exhaustion or information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-68456?
CVE-2025-68456 is a high-severity denial of service vulnerability in Craftcms Craft Cms, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 3.0.0 through 4.16.16, unauthenticated users can trigger database backup operations via specific admin actions, potentially leading to resource exhaustion or information disclosure. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue. Craft 3 users should update to the latest Craft 4 and 5 releases, which include the fixes.
Which versions are affected by CVE-2025-68456?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 3.0.0 | 4.16.17 |
craftcms/cms Packagist | From 3.0.0 | 4.16.17 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.8.21 |
Products include Craftcms Craft Cms.
How do I fix CVE-2025-68456?
Upgrade craftcms/cms to a fixed version for your release line: 4.16.17 or 5.8.21.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-68456 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68456 exists.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-v64r-7wg9-23pr.