{"answers":{"affected":"2 open source packages ship an affected version, including orejime. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-68457 in the wild and no public exploit code.","fix":"Upgrade orejime to 2.3.2 or later.","what":"CVE-2025-68457 is a low-severity cross-site scripting vulnerability in boscop-fr orejime, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-68457 and fix it if it is affected.\n\nWhat it is: CVE-2025-68457 is a low-severity cross-site scripting vulnerability in boscop-fr orejime, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-68457 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- orejime (npm): affected all versions; fixed in 2.3.2\n- orejime (npm): affected all versions; fixed in 2.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68457/ (Markdown: https://insights.sbomify.com/CVE-2025-68457/index.md)","id":"CVE-2025-68457","markdown":"https://insights.sbomify.com/CVE-2025-68457/index.md","name":"CVE-2025-68457","record":{"aliases":["GHSA-72mh-hgpm-6384"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript consent manager","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript by injecting malicious data attributes into HTML elements managed by the Orejime consent manager library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"orejime","vendor":"boscop"}],"cvss":{"score":0.6,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Orejime is a consent manager that focuses on accessibility. On HTML elements handled by Orejime prior to version 2.3.2, one could run malicious code by embedding `javascript:` code within data attributes. When consenting to the related purpose, Orejime would turn data attributes into unprefixed ones (i.e. `data-href` into `href`), thus executing the code. This shouldn't have any impact on most setups, as elements handled by Orejime are generally hardcoded. The problem would only arise if somebody could inject HTML code within pages. The problem has been patched in version 2.3.2. As a workaround, the problem can be fixed outside of Orejime by sanitizing attributes which could contain executable code.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Orejime has executable code in HTML attributes","id":"CVE-2025-68457","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"webpack buildHttp: allowedUris allow-list bypass via URL userinfo (@) leading to build-time SSRF behavior","id":"CVE-2025-68458"},"packages":[{"ecosystem":"npm","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"orejime","purl":null,"source":"GHSA-72mh-hgpm-6384"},{"ecosystem":"npm","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"orejime","purl":"pkg:npm/orejime","source":"GHSA-72mh-hgpm-6384"}],"prev":{"headline":"Unauthenticated Craft CMS users can trigger a database backup","id":"CVE-2025-68456"},"products":["orejime"],"published":"2025-12-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-13","vendors":["boscop-fr"]},"summary":"An attacker can execute arbitrary JavaScript by injecting malicious data attributes into HTML elements managed by the Orejime consent manager library.","url":"https://insights.sbomify.com/CVE-2025-68457/"}