# CVE-2025-68457: Orejime has executable code in HTML attributes

> An attacker can execute arbitrary JavaScript by injecting malicious data attributes into HTML elements managed by the Orejime consent manager library.

- **Severity:** Low 0.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Dec 2025
- **Updated:** 13 Jan 2026
- **Also known as:** GHSA-72mh-hgpm-6384

## What is CVE-2025-68457?

CVE-2025-68457 is a low-severity cross-site scripting vulnerability in boscop-fr orejime, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Orejime is a consent manager that focuses on accessibility. On HTML elements handled by Orejime prior to version 2.3.2, one could run malicious code by embedding `javascript:` code within data attributes. When consenting to the related purpose, Orejime would turn data attributes into unprefixed ones (i.e. `data-href` into `href`), thus executing the code. This shouldn't have any impact on most setups, as elements handled by Orejime are generally hardcoded. The problem would only arise if somebody could inject HTML code within pages. The problem has been patched in version 2.3.2. As a workaround, the problem can be fixed outside of Orejime by sanitizing attributes which could contain executable code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-68457?

2 open source packages ship an affected version, including orejime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `orejime` | npm | All versions | 2.3.2 |
| `orejime` | npm | All versions | 2.3.2 |

Products: Boscop Orejime.

## How do I fix CVE-2025-68457?

Upgrade orejime to 2.3.2 or later.

## Is CVE-2025-68457 being exploited?

There is no known exploitation of CVE-2025-68457 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68457 and fix it if it is affected.

What it is: CVE-2025-68457 is a low-severity cross-site scripting vulnerability in boscop-fr orejime, published on 19 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-68457 in the wild and no public exploit code.

Affected packages and fixed versions:
- orejime (npm): affected all versions; fixed in 2.3.2
- orejime (npm): affected all versions; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68457/ (Markdown: https://insights.sbomify.com/CVE-2025-68457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68457
- OSV: https://osv.dev/vulnerability/CVE-2025-68457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68457/
Summaries are generated and may contain mistakes; the official description above is the record.
