# CVE-2025-68463: Biopython is vulnerable to doctype XML external entity (XXE) injection through Bio.Entrez

> An attacker can exploit an XML External Entity vulnerability in Bio.Entrez to read sensitive files or cause denial of service.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2025
- **Updated:** 8 May 2026
- **Also known as:** DEBIAN-CVE-2025-68463, GHSA-x3vf-39hj-gxr4, PYSEC-2026-1221, UBUNTU-CVE-2025-68463, openSUSE-SU-2026:10537-1, openSUSE-SU-2026:21169-1

## What is CVE-2025-68463?

CVE-2025-68463 is a medium-severity vulnerability in Biopython, published on 18 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Bio.Entrez in Biopython through 186 allows doctype XXE.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-68463?

3 open source packages ship an affected version, including biopython.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `biopython` | PyPI | All versions to 1.86 | None |
| `biopython` | PyPI | All versions to 1.86 | None |
| `biopython` | PyPI | All versions | 1.87 |
| `python-biopython` | openSUSE:Leap 16.0 | All versions | 1.85-bp160.2.1 |
| `python-biopython` | openSUSE:Tumbleweed | All versions | 1.87-1.1 |

## How do I fix CVE-2025-68463?

Upgrade biopython to 1.87 or later.

## Is CVE-2025-68463 being exploited?

There is no known exploitation of CVE-2025-68463 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68463 and fix it if it is affected.

What it is: CVE-2025-68463 is a medium-severity vulnerability in Biopython, published on 18 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68463 in the wild and no public exploit code.

Affected packages and fixed versions:
- biopython (PyPI): affected all versions up to 1.86; no fix listed
- biopython (PyPI): affected all versions up to 1.86; no fix listed
- biopython (PyPI): affected all versions; fixed in 1.87

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68463/ (Markdown: https://insights.sbomify.com/CVE-2025-68463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68463
- OSV: https://osv.dev/vulnerability/CVE-2025-68463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68463/
Summaries are generated and may contain mistakes; the official description above is the record.
