{"answers":{"affected":"2 open source packages ship an affected version, including darkreader. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-68467 in the wild and no public exploit code.","fix":"Upgrade darkreader to 4.9.117 or later.","what":"CVE-2025-68467 is a low-severity server-side request forgery vulnerability in darkreader, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-68467 and fix it if it is affected.\n\nWhat it is: CVE-2025-68467 is a low-severity server-side request forgery vulnerability in darkreader, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-68467 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- darkreader (npm): affected all versions; fixed in 4.9.117\n- darkreader (npm): affected all versions; fixed in 4.9.117\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-68467/ (Markdown: https://insights.sbomify.com/CVE-2025-68467/index.md)","id":"CVE-2025-68467","markdown":"https://insights.sbomify.com/CVE-2025-68467/index.md","name":"CVE-2025-68467","record":{"aliases":["GHSA-x369-mcw8-8rvj"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Dark Reader extension","requires_auth":"none","summary":"A malicious website can force the Dark Reader extension to request style sheets from local servers, potentially exposing local resources.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"darkreader","vendor":"darkreader"}],"cvss":{"score":3.4,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-346","name":"Origin Validation Error"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Dark Reader is an accessibility browser extension that makes web pages colors dark. The dynamic dark mode feature of the extension works by analyzing the colors of web pages found in CSS style sheet files. In order to analyze cross-origin style sheets (stored on websites different from the original web page), Dark Reader requests such files via a background worker, ensuring the request is performed with no credentials and that the content type of the response is a CSS file. Prior to Dark Reader 4.9.117, this style content was assigned to an HTML Style Element in order to parse and loop through style declarations, and also stored in page's Session Storage for performance gains. This could allow a website author to request a style sheet from a locally running web server, for example by having a link pointing to `http[:]//localhost[:]8080/style[.]css`. The brute force of the host name, port and file name would be unlikely due to performance impact, that would cause the browser tab to hang shortly, but it could be possible to request a style sheet if the full URL was known in advance. As per December 18, 2025 there is no known exploit of the issue. The problem has been fixed in version 4.9.117 on December 3, 2025. The style sheets are now parsed using modern Constructed Style Sheets API and the contents of cross-origin style sheets is no longer stored in page's Session Storage. Version 4.9.118 (December 8, 2025) restricts cross-origin requests to localhost aliases, IP addresses, hosts with ports and non-HTTPS resources. The absolute majority of users have received an update 4.1.117 or 4.9.118 automatically within a week. However users must ensure their automatic updates are not blocked and they are using the latest version of the extension by going to chrome://extensions or about:addons pages in browser settings. Users utilizing manual builds must upgrade to version 4.9.118 and above. Developers using `darkreader` NPM package for their own websites are likely not affected, but must ensure the function passed to `setFetchMethod()` for performing cross-origin requests works within the intended scope. Developers using custom forks of earlier versions of Dark Reader to build other extensions or integrating into their apps or browsers must ensure they perform cross-origin requests safely and the responses are not accessible outside of the app or extension.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dark Reader gives users the ability to request style sheets from local web servers","id":"CVE-2025-68467","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Avahi has a reachable assertion in lookup_multicast_callback","id":"CVE-2025-68468"},"packages":[{"ecosystem":"npm","fixed":["4.9.117"],"introduced":["0"],"last_affected":[],"package":"darkreader","purl":null,"source":"GHSA-x369-mcw8-8rvj"},{"ecosystem":"npm","fixed":["4.9.117"],"introduced":["0"],"last_affected":[],"package":"darkreader","purl":"pkg:npm/darkreader","source":"GHSA-x369-mcw8-8rvj"}],"prev":{"headline":"Biopython is vulnerable to doctype XML external entity (XXE) injection through Bio.Entrez","id":"CVE-2025-68463"},"products":["darkreader"],"published":"2026-03-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-10","vendors":["darkreader"]},"summary":"A malicious website can force the Dark Reader extension to request style sheets from local servers, potentially exposing local resources.","url":"https://insights.sbomify.com/CVE-2025-68467/"}