# CVE-2025-68470: React Router has unexpected external redirect via untrusted paths

> Attackers can craft paths to redirect users to external URLs in React Router applications if untrusted content is used in navigation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** CLSA-2026-1775521858, CLSA-2026-1792253394, CLSA-2026-1792269431, GHSA-9jcx-v3wj-wh4m

## What is CVE-2025-68470?

CVE-2025-68470 is a medium-severity vulnerability in remix-run react-router, published on 10 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

React Router is a router for React. In versions 6.0.0 through 6.30.1 and 7.0.0 through 7.9.5, an attacker-supplied path can be crafted so that when a React Router application navigates to it via navigate(), <Link>, or redirect(), the app performs a navigation/redirect to an external URL. This is only an issue if you are passing untrusted content into navigation paths in your application code. This issue has been patched in versions 6.30.2 and 7.9.6.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-68470?

4 open source packages ship an affected version, including react-router. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-router` | npm | From 6.0.0 | 6.30.2 |
| `react-router` | npm | From 6.0.0 | 6.30.2 |
| `react-router` | npm | From 7.0.0 | 7.9.6 |
| `react-router` | npm | From 7.0.0 | 7.9.6 |

Products: Shopify React-Router.

## How do I fix CVE-2025-68470?

Upgrade react-router to a fixed version for your release line: 6.30.2 or 7.9.6.

## Is CVE-2025-68470 being exploited?

There is no known exploitation of CVE-2025-68470 in the wild and no public exploit code.

## Other vulnerabilities in remix-run react-router

- [CVE-2026-55685](https://insights.sbomify.com/CVE-2026-55685/): React Router: Unauthenticated Denial of Service via Inefficient Route Matching (high 8.7)
- [CVE-2026-21884](https://insights.sbomify.com/CVE-2026-21884/): React Router SSR XSS in ScrollRestoration (high 8.2)
- [CVE-2026-42211](https://insights.sbomify.com/CVE-2026-42211/): React Router's vendored turbo-stream v2 allows arbitrary constructor invocation via TYPE_ERROR deserialization leading to Unauth RCE (high 8.1)
- [CVE-2026-33245](https://insights.sbomify.com/CVE-2026-33245/): React Router vulnerable to XSS in unstable RSC redirect handling via javascript: redirect targets (high 8.0)
- [CVE-2026-22029](https://insights.sbomify.com/CVE-2026-22029/): React Router vulnerable to XSS via Open Redirects (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68470 and fix it if it is affected.

What it is: CVE-2025-68470 is a medium-severity vulnerability in remix-run react-router, published on 10 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68470 in the wild and no public exploit code.

Affected packages and fixed versions:
- react-router (npm): affected from 6.0.0; fixed in 6.30.2
- react-router (npm): affected from 6.0.0; fixed in 6.30.2
- react-router (npm): affected from 7.0.0; fixed in 7.9.6
- react-router (npm): affected from 7.0.0; fixed in 7.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68470/ (Markdown: https://insights.sbomify.com/CVE-2025-68470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68470
- OSV: https://osv.dev/vulnerability/CVE-2025-68470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68470/
Summaries are generated and may contain mistakes; the official description above is the record.
