# CVE-2025-68475: Fedify has ReDoS Vulnerability in HTML Parsing Regex

> Attackers can cause denial of service in Fedify applications by sending malicious HTML responses that trigger catastrophic regex backtracking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Dec 2025
- **Updated:** 22 Dec 2025
- **Also known as:** GHSA-rchf-xwx2-hm93

## What is CVE-2025-68475?

CVE-2025-68475 is a high-severity denial of service vulnerability in fedify-dev fedify, published on 22 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Prior to versions 1.6.13, 1.7.14, 1.8.15, and 1.9.2, a Regular Expression Denial of Service (ReDoS) vulnerability exists in Fedify's document loader. The HTML parsing regex at packages/fedify/src/runtime/docloader.ts:259 contains nested quantifiers that cause catastrophic backtracking when processing maliciously crafted HTML responses. This issue has been patched in versions 1.6.13, 1.7.14, 1.8.15, and 1.9.2.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-68475?

8 open source packages ship an affected version, including @fedify/fedify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fedify/fedify` | npm | All versions | 1.6.13 |
| `@fedify/fedify` | npm | All versions | 1.6.13 |
| `@fedify/fedify` | npm | From 1.7.0 | 1.7.14 |
| `@fedify/fedify` | npm | From 1.7.0 | 1.7.14 |
| `@fedify/fedify` | npm | From 1.8.0 | 1.8.15 |
| `@fedify/fedify` | npm | From 1.8.0 | 1.8.15 |
| `@fedify/fedify` | npm | From 1.9.0 | 1.9.2 |
| `@fedify/fedify` | npm | From 1.9.0 | 1.9.2 |

Products: Fedify Fedify.

## How do I fix CVE-2025-68475?

Upgrade @fedify/fedify to a fixed version for your release line: 1.6.13, 1.7.14, 1.8.15 or 1.9.2.

## Is CVE-2025-68475 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68475 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68475 and fix it if it is affected.

What it is: CVE-2025-68475 is a high-severity denial of service vulnerability in fedify-dev fedify, published on 22 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68475 exists.

Affected packages and fixed versions:
- @fedify/fedify (npm): affected all versions; fixed in 1.6.13
- @fedify/fedify (npm): affected all versions; fixed in 1.6.13
- @fedify/fedify (npm): affected from 1.7.0; fixed in 1.7.14
- @fedify/fedify (npm): affected from 1.7.0; fixed in 1.7.14
- @fedify/fedify (npm): affected from 1.8.0; fixed in 1.8.15
- @fedify/fedify (npm): affected from 1.8.0; fixed in 1.8.15
- @fedify/fedify (npm): affected from 1.9.0; fixed in 1.9.2
- @fedify/fedify (npm): affected from 1.9.0; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68475/ (Markdown: https://insights.sbomify.com/CVE-2025-68475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68475
- OSV: https://osv.dev/vulnerability/CVE-2025-68475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68475/
Summaries are generated and may contain mistakes; the official description above is the record.
