# CVE-2025-68476: KEDA has Arbitrary File Read via Insufficient Path Validation in HashiCorp Vault Service Account Credential

> An attacker with TriggerAuthentication permissions can read arbitrary files from the node filesystem via insufficient path validation in KEDA's Vault integration.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Dec 2025
- **Updated:** 22 Dec 2025
- **Also known as:** AZL-72868, CLEANSTART-2026-LW02522, ECHO-3762-3abe-027a, GHSA-c4p6-qg4m-9jmr, GO-2025-4257, MINI-8qf9-p96q-fv4h, MINI-j3ph-cqw9-q3v6

## What is CVE-2025-68476?

CVE-2025-68476 is a high-severity path traversal vulnerability in kedacore keda, published on 22 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

KEDA is a Kubernetes-based Event Driven Autoscaling component. Prior to versions 2.17.3 and 2.18.3, an Arbitrary File Read vulnerability has been identified in KEDA, potentially affecting any KEDA resource that uses TriggerAuthentication to configure HashiCorp Vault authentication. The vulnerability stems from an incorrect or insufficient path validation when loading the Service Account Token specified in spec.hashiCorpVault.credential.serviceAccount. An attacker with permissions to create or modify a TriggerAuthentication resource can exfiltrate the content of any file from the node's filesystem (where the KEDA pod resides) by directing the file's content to a server under their control, as part of the Vault authentication request. The potential impact includes the exfiltration of sensitive system information, such as secrets, keys, or the content of files like /etc/passwd. This issue has been patched in versions 2.17.3 and 2.18.3.

Weakness: CWE-863 (Incorrect Authorization), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-68476?

6 open source packages ship an affected version, including github.com/kedacore/keda/v2 and github.com/kedacore/keda.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kedacore/keda/v2` | Go | All versions | 2.17.3, 2.18.3 |
| `github.com/kedacore/keda/v2` | Go | All versions | 2.17.3 |
| `github.com/kedacore/keda/v2` | Go | All versions | 2.17.3 |
| `github.com/kedacore/keda/v2` | Go | From 2.18.0 | 2.18.3 |
| `github.com/kedacore/keda/v2` | Go | From 2.18.0 | 2.18.3 |
| `github.com/kedacore/keda` | Go | All versions | None |

## How do I fix CVE-2025-68476?

Upgrade github.com/kedacore/keda/v2 to a fixed version for your release line: 2.17.3 or 2.18.3.

## Is CVE-2025-68476 being exploited?

There is no known exploitation of CVE-2025-68476 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68476 and fix it if it is affected.

What it is: CVE-2025-68476 is a high-severity path traversal vulnerability in kedacore keda, published on 22 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-68476 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kedacore/keda/v2 (Go): affected all versions; fixed in 2.17.3, 2.18.3
- github.com/kedacore/keda/v2 (Go): affected all versions; fixed in 2.17.3
- github.com/kedacore/keda/v2 (Go): affected all versions; fixed in 2.17.3
- github.com/kedacore/keda/v2 (Go): affected from 2.18.0; fixed in 2.18.3
- github.com/kedacore/keda/v2 (Go): affected from 2.18.0; fixed in 2.18.3
- github.com/kedacore/keda (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68476/ (Markdown: https://insights.sbomify.com/CVE-2025-68476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68476
- OSV: https://osv.dev/vulnerability/CVE-2025-68476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68476/
Summaries are generated and may contain mistakes; the official description above is the record.
