# CVE-2025-68477: Langflow vulnerable to Server-Side Request Forgery

> Attackers can exploit an API component to perform Server-Side Request Forgery, accessing internal resources and metadata services via crafted URLs.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2025
- **Updated:** 19 Dec 2025
- **Also known as:** GHSA-5993-7p27-66g5, PYSEC-2026-1522

## What is CVE-2025-68477?

CVE-2025-68477 is a high-severity server-side request forgery vulnerability in Langflow Langflow, published on 19 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to version 1.7.0, Langflow provides an API Request component that can issue arbitrary HTTP requests within a flow. This component takes a user-supplied URL, performs only normalization and basic format checks, and then sends the request using a server-side httpx client. It does not block private IP ranges (127[.]0[.]0[.]1, the 10/172/192 ranges) or cloud metadata endpoints (169[.]254[.]169[.]254), and it returns the response body as the result. Because the flow execution endpoints (/api/v1/run, /api/v1/run/advanced) can be invoked with just an API key, if an attacker can control the API Request URL in a flow, non-blind SSRF is possible—accessing internal resources from the server’s network context. This enables requests to, and collection of responses from, internal administrative endpoints, metadata services, and internal databases/services, leading to information disclosure and providing a foothold for further attacks. Version 1.7.0 contains a patch for this issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-68477?

3 open source packages ship an affected version, including langflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | All versions | 1.7.1 |
| `langflow` | PyPI | All versions | 1.7.1 |
| `langflow` | PyPI | All versions | 1.7.1 |

Products: Langflow Langflow.

## How do I fix CVE-2025-68477?

Upgrade langflow to 1.7.1 or later.

## Is CVE-2025-68477 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68477 exists.

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68477 and fix it if it is affected.

What it is: CVE-2025-68477 is a high-severity server-side request forgery vulnerability in Langflow Langflow, published on 19 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68477 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected all versions; fixed in 1.7.1
- langflow (PyPI): affected all versions; fixed in 1.7.1
- langflow (PyPI): affected all versions; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68477/ (Markdown: https://insights.sbomify.com/CVE-2025-68477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68477
- OSV: https://osv.dev/vulnerability/CVE-2025-68477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68477/
Summaries are generated and may contain mistakes; the official description above is the record.
