# CVE-2025-68478: Langflow Vulnerable to External Control of File Name or Path

> Attackers can write arbitrary files to the server by manipulating the fs_path parameter, potentially overwriting critical system files.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2025
- **Updated:** 19 Dec 2025
- **Also known as:** GHSA-f43r-cc68-gpx4, PYSEC-2025-125

## What is CVE-2025-68478?

CVE-2025-68478 is a high-severity path traversal vulnerability in Langflow Langflow, published on 19 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to version 1.7.0, if an arbitrary path is specified in the request body's `fs_path`, the server serializes the Flow object into JSON and creates/overwrites a file at that path. There is no path restriction, normalization, or allowed directory enforcement, so absolute paths (e.g., /etc/poc.txt) are interpreted as is. Version 1.7.0 fixes the issue.

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere), CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2025-68478?

3 open source packages ship an affected version, including langflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | All versions | 1.7.0 |
| `langflow` | PyPI | All versions | 1.7.1 |
| `langflow` | PyPI | All versions | 1.7.1 |

Products: Langflow Langflow.

## How do I fix CVE-2025-68478?

Upgrade langflow to a fixed version for your release line: 1.7.0 or 1.7.1.

## Is CVE-2025-68478 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68478 exists.

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-68478 and fix it if it is affected.

What it is: CVE-2025-68478 is a high-severity path traversal vulnerability in Langflow Langflow, published on 19 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-68478 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected all versions; fixed in 1.7.0
- langflow (PyPI): affected all versions; fixed in 1.7.1
- langflow (PyPI): affected all versions; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-68478/ (Markdown: https://insights.sbomify.com/CVE-2025-68478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-68478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-68478
- OSV: https://osv.dev/vulnerability/CVE-2025-68478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-68478/
Summaries are generated and may contain mistakes; the official description above is the record.
