CVE-2025-68479 Discourse subscriptions are susceptible to takeover

High 7.1 Published Updated

Attackers can modify or take over subscriptions due to missing ownership checks in Discourse endpoints.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-68479?

CVE-2025-68479 is a high-severity missing authorization vulnerability in Discourse Discourse, published on 28 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, some subscription endpoints lack proper checking for ownership before making changes. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.

Weakness: CWE-862

Which versions are affected by CVE-2025-68479?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.5.4, 2025.11.2, 2025.12.1, 2026.1.0

Products include Discourse Discourse.

How do I fix CVE-2025-68479?

Upgrade discourse to a fixed version for your release line: 3.5.4, 2025.11.2, 2025.12.1 or 2026.1.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-68479 being exploited?

There is no known exploitation of CVE-2025-68479 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-68479, GHSA-6gjr-5897-m327.

Is CVE-2025-68479 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free